UpdateAble BAQ wont add more then one row


(trevor olp) #1

So i have a update able BAQ for Table UD100, where im just trying to add in some dimensional data for quality. I am capable of addin one row, but as soon as i add a second row, both rows get deleted on save. If i do a paste update, only the last row of the list of data remains. Has anyone had this problem before?


(Chris Conn) #2

Are you including any KEY data on your new records? If so, are they all unique?


(trevor olp) #3

From my understanding anything Labled as ISKEYFIELD, wont allow you to update it. I am currently only adding in data into the Character01-10 fields.


(Brandon Anderson) #4

You can’t “update” it, but you need to create them initially. That’s how it knows what row is what row.


(trevor olp) #5

Ok, that makes sense. Do I add that I to the initial expression?


(Brandon Anderson) #6

Just add them to your displayed fields, then you can paste insert the values that you want. I don’t know if you can paste insert, or paste update in a BAQ. I think you have to be in a dashboard, but I could be wrong on that one. If you try to make a new row with duplicated key values it will either give you an error, or update the existing one. I’d have to try it to be sure.


(trevor olp) #7

ya, even by adding the key fields and giving them unique values, as soon as i put more then one row, it deletes all rows. when i put into dashboard and i do past update, only the last row remains.


(Brandon Anderson) #8

Did you make them updateable in the BAQ? I think you’ll have to do that too.


(trevor olp) #9

Yes

image


(Brandon Anderson) #10

alright, let me try it here.


(trevor olp) #11

Thank you, i really appreciate the help

Fyi, im on 10.1.400.26


(Brandon Anderson) #12

while I’m messing with this, try removing the multiple row check box in the BAQ. Then do a paste update in the dashboard.


(trevor olp) #13

past update like normal. wont save. refreshes with 0 rows


(Brandon Anderson) #14

So I have a basic dashboard working with UD100. I do not have the multiple rows checked in the BAQ. The paste insert works in the dashboard. I’m in 10.2.200 so I can’t export it and give it to you unfortunately.

Can you look at your UD100 table without the join to the part number? I want to make sure that the UDtable is actually empty.

Here’s some screen shots.

BAQ





Dashboard


(trevor olp) #15

Ok, you nailed it. It did work with the paste update without the multiple rows checked. I really appreciate it. Thank you very much.