Untoggle a non work day?


(Brandon Anderson) #1

So, Dumb question. I just started messing with the calendar in pilot in preparation for making a BAQ that will need one, and I cannot figure out how to remove the non-work day toggle. I’m sure it’s something simple.


(Pierre Hogue) #2

If you click on Toggle day, delete the text… ok.

Verify in your ProdCalDay table if the date under this calendar id is still present…

Pîerre


(Brandon Anderson) #3

It removes it from the calendar view, however if I check the ProdDay table it is still there, (with “non work day” in the exception label.)

That’s annoying.


(tyler fenwick) #4

I’m confused why you can double click on the non work day you entered and see that there is a delete button. But you can’t use it, even when signed in as manager.


(Brandon Anderson) #5

Me too! So maybe it wasn’t such a dumb question. I checked in 10.1.600 and 10.2.200. Same thing.

And it looks like there is no way to make the working day check box checked either. Even if you type in “Work Day”

Anyone else have any other ideas? If nothing “built in” I’ll probably start a support ticket. This doesn’t make any sense…


(tyler fenwick) #6

Yep I’m at a total loss I have tried everything, even developer mode.


(Pierre Hogue) #7

I think by default they are all working days…
You define the working hours depending of the day of the week in Hours per day…

The work days pane we only use it for exceptions and holidays…

But I am stunned to notice the removal of the exception is not trivial…

Pierre


(Brandon Anderson) #8

Well, I submitted a ticket. We’ll see what they say.


(Mark Wonsil) #9

I see that with the pop screen too. However, if I single click and press the Del key, it does ask permission to delete and it will with an affirmative response.

Mark W.

(Changed button to key, my bad)


(Brandon Anderson) #10

Am I doing something wrong? That delete is disabled for me.


(Mark Wonsil) #11

I clicked the physical Del key, not a button.

image


(Brandon Anderson) #12

tricky bastards…


(Mark Wonsil) #13

I’d still report it. It should work on the screen and on the Pop-Up as well - IMHO.


(Brandon Anderson) #14

Yeah I just updated the case stating that I had a workaround, but wanted to submit an enhancement request to make it more intuitive, or at least document it in the help files. It currently says to hit toggle again, which doesn’t work.

also FWIW, it works with the X in the menu on the employee calendar. The popup is still useless though.


(Ernie Lowell) #15

HARDWARE??? This is a software forum… be careful you don’t get yourself excommunicated or something…