Unable to load Memo through DMT


(Katie) #1

I always get an error when I try to load a new memo through the DMT - error message is: 2018-03-28T09:59:51 Part 05001 Unrecognized Guid format.

Right now I have to manually enter all memos, which can be a pain when I have a large amount to do. This is the template I am using. I have all required fields. I cant figure it out…

Company RelatedToSchemaName RelatedToFile Key1 Key2 Key3 MemoDate MemoDesc MemoText CategoryID RelatedToSysRowID


(Aaron Moreng) #2

Can you show what your guid looks like in your data?


(Monty Wilson) #3

Dear Katie,

Have you tried having DMT make its minimal template, and trying to upload using just that first, then adding your fields one by one until the DMT load no longer works?

Sometimes DMT lies about its minimal list of fields, but it’s easy to find out because it will error-out saying such-and-such field does not exist when you try and load it.

Sometimes DMT gives you an error message that hints at the real issue, rather than nailing what the real issue is.

Good luck
…Monty.


(Katie) #4

I looked at the DMT template builder again. I think it has to do with
RelatedToSysRowID Guid RelatedToSysRowID

With other loads you can just leave fields like this blank and it auto fills in. Same with Date/time, user, etc. I guess if this is required data then I defiantly cant do a load. I just think it’s weird because everywhere else you can leave it blank.


(Katie) #5

I went back and included every column from the template builder. Still errors.


(Aaron Moreng) #6

Let’s try Monty’s suggestion and only put in what’s required.


(Katie) #7

That didn’t work either. I’ll try asking Epicor support as well. If it truly doesn’t work I need some kind of work around to create mass memos on parts instead of opening each part and creating a memo. I thought maybe I could do an ongoing UD note field, but then remembered we have problems with those (field says it can hold X number of characters, yet gives error that a note exceeds max length. I believe we were told it might be fixed in a later release).


(Aaron Moreng) #8

So I tried making a memo DMT upload for part and it worked perfectly.
What I did was only use the required columns, which are below:

For the RelatedToSysRowID, this will be the part record you are trying to attached it to. I’d query the database for these

You can definitely add the other columns you need too…