Stock Status Report not working having Stock in Hand

reports

(Prakash6738) #1

Hi all,
very interesting behavior i found while running the Stock Status report for few parts, where the stock is available in part tracker (PartBin). After running the stock Status for the same displays blank Report ??

Any reason behind it ?

I have refreshed the PartBin qty to PartTran process, rechecked there is no allocated or reserved qtys.
Also ran the same report with SSRS report style.

Here are the screenshots,

  1. part Tracker

2.Stock Status selection

3.Report with Blank lines

Thanks


(Chris Crosta) #2

Are two parts marked as “Non-Stock Items”?


(Marty Fleming) #3

What update level are you on? There was a bug in this report prior to about update 10.1.400.18. Fixed in later updates.


(Prakash6738) #4

@MartyF- Currently we are on 10.1.600.4… so i need to fix the bugs ?


(Prakash6738) #5

@E102016- No, the part is Quantity Bearing part…I have already cheked with non-stock option on Stock Status Report form.


(Marty Fleming) #6

It would have been fixed prior to 10.1.600 being released, so I doubt our issue was the same as yours.


(Prakash6738) #7

So i have to update to a latest Update ? now i have a latest update 10.1.600.18 with me on test server.
I will put the live database on this update and will check the results.

will let u know the status…Thanks


(Bruce Ordway) #8

Have you already tried running the refresh utility?

System Management --> Upgrade --> Mass Regeneration --> Refresh Part Quantities and Allocations

The table where summarized Part Quantities are stored can get out of sync.
I’ve seen it enough that I run this utility at least once every couple of weeks.


(Marty Fleming) #9

Prakash, the version we had the bug in was 10.1.400 (note the 400). So what I am saying is that because you are on 600 (18 months later) the bug we encountered will probably have already been fixed in your version already.


(Paul Morgan) #10

Hi Prakash,

This could be an issue relating to upper/lower case. If you look in transaction history was the stock transferred to say bin 1ab1 where your master file bin is actually 1AB1?? if so the stock status report will ignore it. This has been fixed in 10.2…we upgraded from 10.1.600.16 to fix this issue.

Apparently Epicor have fixed certain reports/programs in different versions but all of the case related issue have been fixed in 10.2. We were told by Epicor that we either needed to implement some BPM to ensure capitals were used and run a sql script provided to convert the data.

Hope this helps,

Cheers
Paul


(Caleb Grundmeier) #11

I agree, we have been fighting this issue since upgrading to E10.1.600. Support gave us two “fixes”. SQL fix to run on the database “This fix program goes through the given tables and updates certain fields that are not the same case as the fields on the table where they are a primary key”. The other is a trailing spaces datafix. Both helped but we have to run those each time before we run the report to get an accurate number.

You will also have this problem with the Slow Moving Stock Report but this one also seems to be fixed in 10.2.

If I were you, I would report the issue to Epicor if you haven’t already. They haven’t given me an sense that they are working hard on fixing this report (on the 10.1 version) that our managers use to make business decisions. They just gave me the fixes and sent me on my way. The more people report it, maybe they will get their act together. Depending on the cost of the part that is missing, you could have a severely inaccurate report and you may not even know it!


(Brad Boes) #12

Working on a 10.1.600.15 version and seeing the same exact issue with Stock Status as reported here. The Bin is correctly all caps in this case. wondering what the end results was for your fix.

Inventory dollars are missing from report because of this.

Thanks.

Brad


(Prakash6738) #13

We have reported the case to epicor. Still the the issue has not resolved. will update soon…


(Brad Boes) #14

The support fix did the trick in our case.

Thanks for the update. Hope yours gets resolved also.

Brad