Printing time delays recently very slow. 9.05.701

printing

(Just some cat on a guitar) #1

Lately our printing times have increased substantially.
I have restarted the Process Server and Task Agent which usually helps.
I have a print server which I also rebooted.

We have certain times like shift change where we get a wave of printing activity, could this be a tuning parameter which I could increase ?

Thanks,
Neil


(Nathan your friendly neighborhood Support Engineer) #2

Always start with running the Performance and Diagnostic Tool > Config Check and address any warnings/failures it reports to start.


(Just some cat on a guitar) #3

Since stopping the Process Server and Task Agent didn’t fix it, I went for the nuclear option.

This was finally solved with a full reboot of the Epicor Server as well as the print server and terminal server.

I suspect it was the Terminal Server but at this point it doesn’t matter. Bigger fish to fry.

Neil


(Just some cat on a guitar) #4

I am back to having this problem again.
Does anyone have any ideas why this keeps cropping up ?

Thanks,
Neil


(Dean Chamberlain) #5

One thing we were told by Epicor was to clear the files that are created under /EpicorData. If I understand it correctly, it dumps all the crashed reports here. It won’t let you delete some if they are still connected. We were told to clear as many as we could once a month or so. I hope that helps.


(Dean Chamberlain) #6

It deleted some of my message. The location is servername/EpicorData.


(Just some cat on a guitar) #7

@DeanC thanks for the tip.
I have scripts that clean out all the usual folders so nothing over 30 days should be laying around.
I suspect there is a service that somehow doesn’t release handles or memory that sometimes gets confused.
@aidacra I have installed the Performance and Diagnostics Tool but it is pointing to my Epicor 10 instance.
Do I need to install a different one to get info for my Epicor 9 instance ?
Thanks,
Neil


(Nathan your friendly neighborhood Support Engineer) #8

The E10 PDT cannot be used with E905.

Navigate to \Epicor905_server_name_goes_here\Epicor905\Utilities\E9 Performance Diagnostic Tool

right-click on the Setup.exe and run as admin.

Then, launch the E9 Performance Diagnostic Tool

Tools > options.

Fill in your specific server name, port (9401 for production by default), a security manager username/password, and the BO directory (which is your client folder)

image

Click Update.

Click Config Check tab.

Click Check Configuration.

Bob’s your Uncle.

Hope that helps.
–Nathan.


(Just some cat on a guitar) #9

@aidacra thanks for the info. I guess I had the Epicor9 diagnostics after all.
The only thing that jumped out at me was this.


I thought that I was running the recommended settings but I could be wrong.
We have probably 50 active sessions with 20 MES sessions among those.
Should I up the numbers ?
Thanks,
Neil


(Nathan your friendly neighborhood Support Engineer) #10

I don’t have the KB numbers of the E905 rules in our new epiccare system but if you create a case I can send you info from our previous KB system.


(Mark Rowley) #11

Hi
can this diagnostics tool be ran whilst the app servers are turned on?


(Nathan your friendly neighborhood Support Engineer) #12

Absolutely, yes.


(Mark Rowley) #13

Any advice for the below results?


(James Hung) #14

This looks like a database issue and is part of the performance. Basically there are a number of non-indexed tables which means searches will take longer to run.

I would consult with a DBA on what to do with this.


(Just some cat on a guitar) #15

image

image

@aidacra is this the setting you are referring to ?

Thanks,
Neil