Performance Diagnostic Tool Errors Out ( PDT )


(Jonathan Lang) #1

I thought I would share with the group my little adventure with Performance Diagnostic Tool (PDT) in hopes it will help someone who encounters this issue and maybe get down to the root cause of why this happens.

Problem:
After installing PDT from the Epicor Administration Console (EAC) i get the following error:

image

Cause and Solution:
The folder, PDT10 at %UserProfile%\AppData\Roaming\Epicor Software\ needs to be deleted before you start the Performance Diagnostic Tool.

Troubleshooting:

  1. Tried loading the PDT on a laptop with Windows 10. The first install works as it should. When the PDT is closed and reopened no error is displayed at all and the program doesn’t execute.
  2. Installing .NET 4.7 doesn’t correct the issue.
  3. Uninstalling and reinstalling .NET doesn’t work.
  4. Deleting files in %temp% has no effect.
  5. deleting all .cch in %UserProfile%\AppData\Roaming\Microsoft\CLRSecurityConfig2.0.50727.312\security.config.cch and C:\Windows\Microsoft.NET\Framework \2.0.50727\CONFIG has no effect.
  6. Uninstalling PDT with Revo, and reinstalling has no effect.

Revo Uninstaller is the program of choice when uninstalling programs from your server and desktop:
Try Revo Here

I thought I would share this with you all in case this happens to anyone else. This took hours to figure out why I couldn’t use PDT any longer.

The last time I used PDT successfully was when I was setting up our Production Application Server and I was using PDT to troubleshoot the server configuration and some issues with the Sales Configurator in 10.1.500.x. Since then I have upgraded to 10.1.600.22.


Performance and Diagnostic Tool
(Jonathan Lang) #2

The solution is as follows:
Delete the folder PDT10 at %UserProfile%\AppData\Roaming\Epicor Software\ needs to be deleted before you start the Performance Diagnostic Tool.


(Mazin Asmar) #3

In 10.1 its E10PDT