MTO AR Invoice Goes To Review Journal (not balanced)


(Rick Bird) #1

Epicor 10.0 customer for many years now, they do product sample runs as MTO all the time and the AR Invoice doesn’t seem to have any issues. However today there is an AR Invoice that when they try to post it goes to Review Journal. When I checked the Edit List, lo and behold it doesn’t balance, the ‘Sales’ credit transaction is not there. I checked the Product Group on the Sales Order, Job & Invoice and they are all the same and the GL Control is setup properly and it’s the same Product Group they always use, ‘Samples.’ All the review journal says is ‘transaction out of balance.’ Things we’ve tried
-Remove the Invoice from the group and regenerate it (Get > Shipments)
-Reopen the Job & try to regenerate the invoice
-All the Cost Elements were blank, so we tried setting those manually, enabling COSPostingReqd, no changed, deleted and regenerated
-Moving the Earliest Applied Date back a month.

The only odd thing is that the Job was completed last month and all WIPCapture was done, and then it was shipped from the Job this month. I’m not sure how odd that is, I would think that type of thing would have happened before.


(Mark Wagner) #2

I assume the job has a demand link with a production quantity otherwise you probably would not have any transactions

Does the sales order line have a quantity on it?

Anything on this particular customer as far as billing terms or billing days?


(Rick Bird) #3

Yes, a good demand link and it looks fine.

Yes, but I just noticed that the Sales Order line has a UOM of SH (sheets), the Sales Order Release has a UOM of EA (each) as does the Job Demand link, but the invoice and pack UOM is SH, I wonder if that could have something to do with it, I wouldn’t think so. I will look into this later today.

I don’t see anything, they are setup as Weekly, All Days, Billing Day 1… much like many other customers.

Thanks Mark! I will look into the UOM thing this evening.
I would appreciate anyone else’s insight.
I just found out that they are not on Support, sigh. Apparently it’s too expensive.


(Brad Boes) #4

Rick,

It sounds like there is an expected GL account that is not setup. Trace the GL controls back. There may be an invalid account listed in the GL controls.

Brad


(brett manners) #5

If you are feeling adventurous you can turn on the Post Engine logger and look for clues in there.

Under Financial management -> General Ledger -> General operations -> PE Log Viewer.
Turn on the log for the transaction you have an issue with (see the transaction tab of the PE Log Viewer). Run the posting again (I think you can also run the validate process from the review journal). This will create a log you can open and dig through. Look for the details of where the engine is trying to find an account but gets nothing.

Here what a log with an error looks like.

Brett


(Rick Bird) #6

I looked in the UOM thing and corrected them all to match and repulled the invoice, no change, still out of balance.

Thanks Mark!


(Rick Bird) #7

Thanks Brad, that’s the first thing I did, all setup correctly.
Selling samples as make direct is a common function for this company and I found hundreds of examples of this exact scenario and everything went through fine.
There is something different here…


(Rick Bird) #8

Thanks Brett, I really think this would help me ID where the problem is.
However, after enabling the AR Invoice (heck I even enabled ALL for the company in question) and logging out and back in and attempting both a repost AND revalidate in the Review Journal, when I attempt to bring up the PE Log Viewer I get the error message: ‘Impossible load information from PE Log’
image
I looked for a file in the location specified on the Settings tab as Export & Import File and there was no pelog.xml, so I created it and re-enabled, still nothing.
Not sure what else to do to get this working.

When I attempted to use the search to recall a PE Log, I get the error ‘Logging file is empty.’
image
Is there some sort of initialization to create the log file?
It sounds like the log file is an actual file and not stored in the database.
Any help anyone can provide would be appreciated.


(brett manners) #9

Rick,

To generate the log you need to trigger the posting engine to run. I usually do that by validating the review journal or by cancelling the review journal and posting again.

Brett

Brett Manners
ERP Systems Manager

** Total Marine Technology**
1 Ambitious Link, Bibra Lake WA 6163
PO Box 3054, Success WA 6964
P: +61(8) 9411 6500 W: www.tmtrov.com.auM: 0400 227 371
E: Brett@tmtrov.com.au

Please consider the environment before printing this email or its attachments.


(Rick Bird) #10

Ok, tried it again and it generated a log… but everything I check for GL controls looks ok.
We would expect the GL Control used to be based on the Order Line/ Invoice Line Product Group, but I don’t see that being evaluated in the log. but this is my first time trying to read something like this. I have attached the log in case anyone can correct what I am missing.
pelog.xml (111.8 KB)

In addition, reviewing the linked Job, it looks like WIP Variance was cleared BEFORE the Shipment… could that be the reason for this problem? There’s nothing left to credit against this job?


(Rick Bird) #11

OH FOR HEAVENS SAKE!!!
I found the problem, someone enabled the ‘Intercompany’ flag on the customer, eventhough the customer is NOT an Intercompany customer. Somehow that hung it up, but I didn’t see anything in the pelog to indicate that it was trying to determine based on that setting, perhaps someone can enlighten me.
Anyways…
Thanks everyone!