Help not working in 10.2.100.8


(Paul Morgan) #1

Hi there,

I logged this with Epicor and it has stumped him and he asked to refer to our IT admin…which our servers and network infrastructure is looked after by an external company. This has been logged with them but they have not look at it yet.

When we upgraded to 10.1.600.13 back in December for some reason it stopped working and the consultant pointed it to the test server…not good but it worked. When we upgraded to 10.2 this could not be done as something the backend has changed that meant this was no longer possible.

If we to browse to http://E10ServerName/ a message saying This page cant be displayed shows but for some reason HTTP://Localhost/ worked.

We have uninstalled and reinstalled help just in case there was a corruption.

Epicor said that they think that something seems to be masking the IIS via server host name and ip address as well.

Anyone else seen anything like this??

cheers,
Paul


(Prakash6738) #2

Have you installed a new extension for Help ? if yes ,then try to browse the directory from IIS server.
if error occures, it show the error code something like 404 or 500.


(Tom Hulbert) #3

Take a look at the helpserver uri in the config. We had issues going from 10.1 to 10.2 (+a few incrementals) where our help wouldn’t load because the address was incorrect.


(Paul Morgan) #4

Hi Prakash,

thanks for your reply. Using the copy url option in the help extension tab and pasting it into a browser we get the message “This page can’t be displayed”… see attachment.

browser error.docx (70.2 KB)


(Paul Morgan) #5

Hi Tom,

The url is correct.


(Prakash6738) #6

Which application pool you have used in your installed Help Extension ?
see the reference …


(Prakash6738) #7

Also chek the following link may work for you as @apathy311 suggested…


(Sanjeev Gupta) #8

Pls do the following steps: -

  1. IIS- Help Website - Directory Browsing – Enabled
  2. Copy Help Url and configured in company maintenance
  3. Go to Epicor Client Folder (ex - C:\Epicor\ERP10\LocalClients\ERP10)
  4. Open ConfigEditor.exe (Run as Administrator)
  5. Select correct sysconfig file and open
  6. Click Help Option
  7. Paste Help Url in helpserver
  8. Save and Close
  9. Recycle IIS Pool
  10. Try and check

(Dan Edwards) #9

It sounds like help is installed correctly and you have some potential host name or binding issues that are causing some problems. The fact you can access using localhost typically means the install is ok. Take a look at your IIS bindings (may not be the same as the screenshot but should be similar). Also, on the server that hosts the help, from a command line, run the command ping -a 127.0.0.1 and see if it responds with a server name