Error after upgrading from 10.1.500.8 to 10.1.500.37


(Joshua Straight) #1

We upgraded last night from .8 to .37 and are running into an issue today that Epicor Support is unsure how to solve.

The Payment Method Entry table is not loading and gives an error stating:

Message: The requested service, ‘net.tcp://w2k12epicor/Epicor10LiveApp/Erp/BO/PayMethod.svc’ could not be activated. See the server’s diagnostic trace logs for more information.
Program: CommonLanguageRuntimeLibrary
Method: HandleReturnMessage

Event viewer shows this:

WebHost failed to process a request.
Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/39449526
Exception: System.ServiceModel.ServiceActivationException: The service ‘/Epicor10LiveApp/Erp/BO/PayMethod.svc’ cannot be activated due to an exception during compilation. The exception message is: Method ‘ChangeMXSATCode’ in type ‘Erp.Services.BO.PayMethodSvcFacade’ from assembly ‘Erp.Services.BO.PayMethod, Version=10.1.500.0, Culture=neutral, PublicKeyToken=5d3fa3c7105d7992’ does not have an implementation… —> System.TypeLoadException: Method ‘ChangeMXSATCode’ in type ‘Erp.Services.BO.PayMethodSvcFacade’ from assembly ‘Erp.Services.BO.PayMethod, Version=10.1.500.0, Culture=neutral, PublicKeyToken=5d3fa3c7105d7992’ does not have an implementation.

It looks like it’s trying to load a Mexican CSF but we do not (nor have we ever) had that.

Has anyone ever run into this?


(Haso Keric) #2

Do you have any Industry Extensions such as MICR Check? Based on the MX STAT Code Error you probably ran across this:

You are going to have to go to EpicWeb and Download an updated MICR Package. Just be aware that the Client ZIP File usually is packaged wrong, you will need to unzip it and re-zip it so it does not sit in a subfolder.

Reach out to lagomez [at] epicor [dot] com - if the Package on EpicWeb is not updated, he sent me the fix.

[EXTERNAL] Pay Method Entry - Error due to 10.1.500.29 Mexico SAT Code Changes

Excellent news, please let us know if you face up any other issue with the customization. The SharePoint link that Melissa sent you should be updated with the latest version of MICR Checks by tomorrow at most.

Thanks!

Luis Alejandro Gomez
Custom Solutions Group - Americas


(Joshua Straight) #3

Yes we do. Epicor walked us through fixing the web.config file after the update but that was the only guidance they gave us.


(Joshua Straight) #4

Sorry for the short reply on Friday evening. I wasn’t near a computer all weekend and on mobile the photos in your post were not showing.

I followed your instructions and replaced the DLL files and it worked like a charm and the tables are now working again. Thank you so much for this solution. Epicor Support wanted us to re-implement our entire DB server to fix it.


(Utah Taylor) #5

You should share with them the answer that you received here if you haven’t already.


(Joshua Straight) #6

I did and they basically said “Glad we could help” and closed my ticket.


(Haso Keric) #7

Next time ask for Nathan Anderson lol @aidacra =)


(Joshua Straight) #8

One more question for you about the MICR checks after the upgrade. When doing a manual check the payment number has to be entered on the AP Payment Entry for each payment. Then in Process Payments we previously always clicked Override and changed the next check number to match to the items in the Payment Entry (otherwise Process Payments would skip a number for each item, for example if you were doing one manual check #18, Process Payments would show #19 and you had to change it back to #18.

After the update when AP tries to override it comes up with an error saying that the check number must be unique. I have run several queries to make sure nothing was wrong with the check numbers and it appears fine. Process Payments is just seeing it as duplicate due to it being in Payment Entry.

Have you run into this?