DMT: PO Receipts


(Joe Rojas) #1

Hi All,

E9.05.702A

I am trying to use DMT to create PO Receipts.
I have all the required fields and the additional fields that I need to populate all the data but when I run DMT (Add New Only), each record gives me the error: Table: RcvDtl Msg: Record not available
Prior to creating the lines, I have created the Receipt Header records without issue.

Any ideas on what I am missing?

Here is a link to me CSV file if you’d like to take a look.
https://1drv.ms/u/s!Apl97fTCt18xzQ8BbsRv8FQCaBAm

JOE ROJAS
Epicor Applications Manager
VENTION MEDICAL
A NORDSON COMPANY

261 Cedar Hill Street | Marlborough, MA 01752
DIRECT: 508.597.1392 x1625 | MOBILE: 774.826.9245
EMAIL: JoRojas@ventionmedical.commailto:JoRojas@ventionmedical.com | WEB: ventionmedical.com http://www.ventionmedical.com/

This communication may contain information that is confidential, proprietary or exempt from disclosure, and is intended only for the use of the individual and/or entity it is addressed to. If you are not the intended recipient, please note that any other dissemination, distribution, use or copying of this communication is strictly prohibited. If you have received this message in error, please notify the sender immediately by telephone or by return e-mail, and delete this information from your computer.


(Mark Damen) #2

Hi

You’ve got duplication within the PackLine field. Drop this field, and allow the system to auto generate. If it does insist on having it, then put the column header in but leave the field empty.

Regards
Mark


(Joe Rojas) #3

Mark, thanks for the quick response.
I didn’t catch the Pack Line field issue but I did as you said and now I’m getting a new error: Syntax error: Missing operand after ‘=’ operator.
This one has me lost.

JOE ROJAS
Epicor Applications Manager
VENTION MEDICAL
A NORDSON COMPANY
DIRECT: 508.597.1392 x1625 | MOBILE: 774.826.9245


(Mark Damen) #4

I notice you’ve got items in the VendorNumVendorID with spaces, and your fields in the CSV are wrapped in “ “.

Try just the first line of the import, or first order perhaps. If that works, then look for differences. Spaces will likely give it a headache in my experience.


(Chris Crosta) #5

Joe,
Just a thought, the header isn’t marked as shipped is it? I have seen some errors using DMT that have sent me off in a completely different direction than what the error seemed to indicate.


(Joe Rojas) #6

I will test this out. Thanks Mark.

JOE ROJAS
Epicor Applications Manager
VENTION MEDICAL
A NORDSON COMPANY
DIRECT: 508.597.1392 x1625 | MOBILE: 774.826.9245


(Joe Rojas) #7

Hi Chris.
Thanks for the feedback. I have confirmed that they are not marked received.

JOE ROJAS
Epicor Applications Manager
VENTION MEDICAL
A NORDSON COMPANY
DIRECT: 508.597.1392 x1625 | MOBILE: 774.826.9245


(Bob Beaghan) #8

We had the same error as in your initial post. Epicor Support provided the suggestions below. I have not had the chance to go back and try them yet.

  1. Make sure that your fields are ordered in the spreadsheet as they would be manually populated via the entry screen.
  2. The ‘PackLine’ field should be set to “0” (zero), this will tell the system to assign the next number in the internal sequence to the Lines.
  3. You should include a ‘ReceivedTo’ line, which should be set to “PUR-STK”.

(Harry Nguyen) #9

Setting ‘PackLine’ field to 0 does work for me. Thank you for the information.