BPM Emails not working all of a sudden


(Andrew Koemm) #1

Does anyone have any issues with BPM’s not sending out emails all of sudden. Since this past Wednesday, I have 2 BPMs that stopped sending emails or something in the back-end is not working correctly.
Here is the interesting part, the BPMs work fine in Pilot. I did not make any changes to these BPMs.

I disabled/reenabled the BPMS. No results. I compared the email settings of Live with Pilot, exactly the same.
I don’t know what could have happened. This is frustrating because my users rely on these emails.
Epicor Support doesn’t seem to know why it works in Pilot and not Live


(Andrew Koemm) #2

I am able to send temporary passwords via email through E10. But why these 2 BPMs all of a sudden???


(Mike Watkinson) #3

Can you try to create a test BPM that is super simple that sends a test email to you and see if that works?


(Haso Keric) #4

Via SQL Studio Query these tables and see if there is anything hanging in the Queue:

Ice.BpActionQueue
Ice.BpActionQueueData
Ice.MailQueue

I once had 1 record hanging up everyone else, once I removed it due to a Ice.SessionState record missing - everything else processed.

SELECT * FROM Ice.BpActionQueue LEFT JOIN Ice.SessionState ON Ice.SessionState.SessionID = Ice.BpActionQueue.SessionID ORDER BY QueueNum ASC; 

But if you go to your Task Agent inside the Server Folder (Ex: C:\inetpub\Epicor) and look at the Logs or Task Agent Events you should see something like

Query failed to run
An error occurred while executing the command definition. See the inner exception for details.
(ctx, id) => ctx.BpActionQueueData.With(UpdLock).Where(row => (row.ForeignSysRowID == id)) 

(Andrew Koemm) #5

I am a SaaS client. I do not have this type of access.


(Nathan your friendly neighborhood Support Engineer) #6

Those tables should be accessible via BAQ.