10.2 Log in issue


(William) #1

Just set up 10.2 for testing and got this error-The Single Sign on issue. Anyone found a way around this?

Application Error

Exception caught in: mscorlib

Error Detail

Message: VERSA\wcremer is not setup for single sign-on.
Program: CommonLanguageRuntimeLibrary
Method: HandleReturnMessage

Client Stack Trace

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Ice.Contracts.SessionModSvcContract.Login()
at Ice.Proxy.Lib.SessionModImpl.Login()
at Ice.Core.Session.InitSessionMod(String asUrl, Boolean fwVerCheck, String companyID, String plantID)
at Ice.Core.Session.InitSession(Action setCredentials, String asUrl, LicenseType licenseType, String pathToConfigurationFile, Boolean fwVerCheck, String companyID, String plantID)
at Ice.Core.Session…ctor(String userID, String password, String asUrl, LicenseType licenseType, String pathToConfigurationFile, Boolean fwVerCheck, String companyID, String plantID)
at Ice.Core.Session…ctor(String userID, String password, LicenseType licenseType)
at Ice.Lib.LogOn.CreateSession(String userID, String password, String appServerUri, LicenseType licenseType, Boolean useAzureADFallback, Object azureADOwnerWindow)
at IceShell.Apps.LogonDialog.logOn(String userID, String password, Boolean promptUpdatePassword)
at IceShell.Apps.LogonDialog.AutoLogOnUser()


(Haso Keric) #2

Somewhere, somehow you enabled SSO. =)


(Jose C Gomez) #3

That user isn’t setup for SSO, log in with a different account and go fix them in User Maintenance. If none of your users use SSO, then you deployed the wrong AppServer connection scheme. Re-Configure / Re-Deploy


(William) #4

No we use SSO, but when I first started it, it still asked for a password and the SSO didn’t work. And when I went to log in, it gave me REST error on log in. So I used the manager log in and changed a few things on my user account and now we get the current issue. I will log in as someone else and try that.


(Carlos Quintanilla) #5

The error appears when you are connecting to an epicor application server configured with a
image
If that’s the case your user VERSA\wcremer needs to have a valid windows domain and user configured on their user profile.
It could also happen when you are accessing an application server configured as
image
but the flag Require SSO is checked (true) on the user profile.