Two Epicor Users accounts slugish and unresponsive


(Stewart Mc Donald) #1

Hello Everyone,

We have run into an issue in which two users accounts are responsive and sluggish 99 percent of the time.

What happens is they go into an NCR to updates and when the screen comes up, its constant hour glassing and shows No response for several minutes. When user types in the comments fields, the same issue occurs, sometimes worse.

Steps done to troubleshoot:

  1. Changed to a laptop with more RAM
  2. Clear user cache in the client
  3. Had user logon to my laptop to do the steps, hourglassing still persisted.
  4. Logged in on my laptop and on users laptop with my account, they are able to do their tasks with no delay.

Is there anything that can be done with the user account to speed it up? I have searched for user maintenance but do not see anything in Epicor.

Any assistance would be greatly appreciated

Regards,

Stewart McDonald.


(Nathan your friendly neighborhood Support Engineer) #2

I would recommend UI traces from both userA and userB that experience the problem, and userC who goes through the exact same steps as userA and userB but doesn’t experience the issue. If you can attach all three UI trace logs to this thread, I’d be happy to review.

BTW, great troubleshooting steps!

~DISABLE SYSTEM MONITOR (to eliminate “noise” in the UI trace):
NOTE: while the system monitor is disabled, the logged in user will be unable to process client-side reports.

  1. Navigate to System Setup > System Maintenance > System Monitor.
  2. File > Exit.

~ENABLE TRACE LOGGING (CLASSIC):

  1. From the main menu, Options > Tracing Options.
  2. Tick the following options:
    a. Enable Trace Logging.
    b. Write Full Data Set.
    c. Include Server Trace.
    d. Write Call Context DataSet.
    e. Write Response Data.
  3. Click Apply button and then minimize the Tracing Options Form (but don’t close it).

~NAVIGATE TO THE MODULE/AREA THAT YOU WANT TO COLLECT THE UI TRACE DATA:
Launch the module/process whose performance you want to measure or need to collect the dataset. Add new records, modify records, run processes, and so on.

~OUTPUT UI TRACE DATA:

  1. Open the minimized Tracing Options Form. Note: if it was closed, relaunch it by going to Options > Tracing Options from the Main Menu.
  2. Click View button, then File > Save As and select a location that can be easily found (Desktop for example).
  3. Send in the UI trace file from the previous step into the support analyst that requested it.

(Surendra Pal) #3

Agreed with @aidacra suggestion. but I had same issue previously.
Solution I applied.

  1. delete recreating the user.
  2. created new user id

(Stewart Mc Donald) #4

Hi,

I think at the moment I would like to try and recreate the users as they are getting very frustrated and do the trace on our Pilot server (same issue occurs on a copy down).

When I try to delete the user I am getting the following error. I tried this in Epicor and on the Eplicor Admin Console.

Delete not allowed. Referenced by at least one Employee

Any suggestions?


(Heather Marie) #5

Just a thought, maybe I’m way off here, but have you tried to clear all Personalizatons for these users?

Personalizations for a user can be found under Customization Maintenance and there is also a Personalization Purge

image

image


(Jeff Johnson) #6

We have some users that have an employee login ID#, but are not hourly. They leave themselves “clocked in” to MES year-round. We found that after a while their accounts would get slower and slower. The solution was to clock them out of MES, then back in.


(Tim Shoemaker) #7

Is this in a regular client or in the MES client? If MES client, the problem could be that the two users have not clocked out for many days and there is a very large set of pending transactions to load. I have seen this before and once they clock out and in again the problem goes away.


(Stewart Mc Donald) #8

This is in the regular client. Users do not use MES.

It is possible they are setup for MES but do not use it. Would them being setup as MES cause a backlog in their account?


(Jeff Johnson) #9

When you say NCR are you talking about Nonconformance? Users need an EmpID# to enter those, so they may have “clocked in” years ago and just forgotten about it. In that case they should definitely load up MES and clock out/in.


(Stewart Mc Donald) #10

Yes, the users use Nonconformance, and Inspection process entry. Its sluggish when they do any tasks, update, search etc.

I asked the users about the MES, and they said they have never logged into MES. I checked their account on the Pilot and it asked me to login, so nobody was logged in at the time.

is there a specific process the users should be doing with MES before entering NCR? Is MES login required to create the NCR reports or can they just use employee number? Issue is only with these 2 users that are on the Quality team, no other department reports any issues with Epicor performance.


(Jeff Johnson) #11

It really sounds like the issue we had… Just out of curiousity, if you go into Production Management->Job Management->General->Shop Tracker, then open the “Who is Here” tab and hit Refresh, do those employees show up? You can do this in Live without causing any problems.


(Tim Shoemaker) #12

Hmmm… if they dont use MES… did they at some time in the past log into Office MES? I have never heard of it slowing down from Office MES, but there is always the chance… Like @jeffj suggested, run the Shop Tracker and see “Who Is Here”… This is my typical first step when someone says that MES is slow. I look for users that clocked in before today.


(Stewart Mc Donald) #13

Ok, so I looked at the list of users under “who is here”, and those users affected do not show as ever being logged in at all. Is having them login to MES something I should try to have them do?


(Stewart Mc Donald) #14

Wanted to provide an update on this as we seem to have found issue.

Our Quality users have several customer BAQ boards setup in their custom settings. Refresh interval was set to 1 min (by default), which seem to have caused the performance issue. Users changed the refresh interval from 1 min to 15 min, and Epicor performance is normal now.

We are monitoring further, but this appears to be the cause.