Task Agent - Log file

epicor

(Chia Chang) #1

When the task agent goes down, is there a log file to view what is causing it to stop? We have a weekly sql backup job that runs and looking to see if that might be causing the task agent to stop. It seems to also be stopping the appserver services also.


(Jose C Gomez) #2

Event Viewer on the Server that is running the task agent.


(Chia Chang) #3

I didn’t see anything related in the Event Viewer except the error below when our VMWare takes a snapshot and then the messages after it goes haywire.


(Jose C Gomez) #4

There’s a custom event called Epicor Task Agent Event (under custom events)


(Chia Chang) #5

I don’t see the Custom Events. Where is it located?

image


(Jose C Gomez) #6

Ugh sorry I didn’t realize you were in 9 :frowning:


(Haso Keric) #7

Chai Chang why?? you not on Epicor 10, making it hard to support you… @Chris_Conn is less experienced with v9.


(Chris Conn) #8

#Facts


(Jenn Lisser) #9

I used to be on 9.05 in a VM environment and had the same problem. We thought it was an issue with losing connection between our SQL and app serveres (had them split out) during snapshot. Our workaround was to schedule a batch to restart the app services after the VM snapshot every night. You can find the batch file by searching this group.
Jenn


(Chia Chang) #10

Were you ever able to find the root cause if this was indeed due the VM snapshots causing the task agents to go down? We did notice that in PET, the task agents status was “running” but when looking in system monitor, all the tasks were going to scheduled task.


(Jenn Lisser) #11

Not sure if it’s root cause, but explanation was the connection between app and SQL servers gets lost during a VM snapshot when you have them separated. At that point our options were to run on 1 server or schedule a restart task - restart task was easier.
This is much better in 10.0 and forward, I promise!

Jenn Lisser

ERP Business Analyst

Perlick Corporation


(Chia Chang) #12

Was there a way to verify there was a lost connection between the app and the sql servers? Our task agent servers are on a different server than our sql servers. We do a VM snapshot every evening at 9pm but it happens randomly.


(Jenn Lisser) #13

We didn’t have a way to verify. The batch I setup just restarted the task agents – I think it was ½ hour after snapshot. The snapshot was after 2nd shift ended, so I just needed to restart task agents before the overnight batches
ran. We didn’t have a 3rd shift.


(Chia Chang) #14

How do you prove that the VM snapshot was a direct correlation with the task agents going down that required the workaround to restart the task agents? We’ve had this environment running for over 3 years and we do understand it goes down once in a while so we’ll need some “verification” the VM snapshots are causing the issue to pursue the workaround now.


(Chia Chang) #15

The task agent is going down outside of the VM snapshot evening hours during the day so it could rule out the VM snapshot issue. We are thinking when we do a server/client file refresh on the test server, this is causing the task agent to go down. How often do you refresh or sync your server/client files? We do it every 30 minutes in the test environment.


(K White) #16

It was my understanding that if you tried to take a back up of the server and touch the DB files it would stop Epicor. We had that issue with V6 and when we went to E9 and did backups…we excluded the DB files. I think it was a progress thing…at least i remember someone mentioning that but I don’t have any details. Just what happened and avoided… :wink:

At least this was my understanding of our experience.


(Chia Chang) #17

By DB files, you mean the Epicor905 server files…correct? Could you clarify “take a back up of the server and touch the DB files”? We do take a sql db backup copy nightly but it happens during the day also so we’re thinking it has something to do with syncing the Epicor905 files every 30 minutes that it would increase the likelihood of the task agent going down?


(K White) #18

I mean like our Symantec back up that we take of the server daily. We back up certain files and do not back up the Epicor DB files (\Servername\Epicor\Epicor905\DB). We take a SQL backup daily and those files are backed up.

How often is it stopping?


(Chia Chang) #19

It has been stopping 1-2 times per week for the last three months. It seems to be random though. Below is the powershell script we use to sync the Epicor files across our servers. We’re thinking this continous 30 minute sync of the Epicor files is what is causing the task agent to go down when it sync’s to the task agent server.


(Haso Keric) #20

@cchang

Find your oe102a_wrk folder and there will be 3 .log files in there such as:

  • admserv.log
  • cmdplugin.log

See if they reveal anything.

// Your path may differ
C:\Epicor\oe102a_wrk

The second location to look at is your Epicor Server logs, the Task Agent should be logging there…

// Your Path may Differ
\\MYSERVER\c$\Epicor905\Server\logs

2019-02-19_1840