Table in sync or data model in sync still yellow after data model regen

e10

(Steve van Niman) #1

Why, after adding a UD field, then doing a data model gen followed by a app pool recycle, the Table in sync or the Data Model in sync is still yellow? Seems like 50% of the time, we have to regen again, then every thing is in sync.

My guess is it’s applying updates and if the table itself is large, it’s timing out on the update. Thus the subsequent regen complete the update. But this is only a guess.

We’re on 10.1.400.32

Thanks,
Steve


(George Hicks) #2

Steve;
Since we updated from .200 to .300 I have the same issue only worse.
I can regen several times to no avail,but when I reboot the server, all is well and I get the Green light.
Anyone else having this issue? A real PITA.
George Hicks


(Jeff Gehling) #3

This is happening for us as well after upgrading to 10.2.300.9. All fields are there, but no matter what the status is still yellow. Support couldn’t figure out the issue.


(Pierre Hogue) #4

Same in 10.2.300.11

Noticed it during our testing…


(Bart Elia) #5

Turn on the system host trace and check what it gives for the success or failure on the Data model version check after app pool recycle


(Haso Keric) #6

I know what it is… I was just nagging Bart about it 2 weeks ago.

So the fields are there and the Yellow is misleading… Use the “List” View! Then make sure your

  • Integers have a default of 0 in the List View (Somehow the List and Detail Dont Match)
  • Booleans have a default of false NOT BLANK! (I also changed any that had no to false)
  • GUIDs have a default of 00000000-0000-0000-0000-000000000000
  • Your Decimal format might be >>>9.9999 with Decimals 4 but the Default Value in List View might be 0 set it to the correct 0.0000

As you are setting the defaults you might notice your Table goes green and in sync. As you are switching btw Detail/List you can notice the Default’s dont match. Once you fix them in the List View your Table goes in sync! It only took me like 7 hours to figure it out lol I even poked around with all Epicors Stored Procedures and SQL Debugging.

The Problem that seems to happen is 400, 500 and earlier versions allowed you to have some blank defaults, which in 10.2 does not like. For me it was Migrating from E9 I had Integer with BLANK which in E9 was fine in 500 it was fine… but in 10.2 it was not.

Fix the Default Initial Values via List View and you should be good. Dont let the Detail Tab Fool you =) If its still Yellow then there is 1 or more Defaults you missed or don’t match the format.

PS: Even when I had Integer set as 0… I set it back to 1 and saved and back to 0, triggered an update and I went green on a table. Even there the 0 didn’t really take until I re-triggered an update.

There really was no failure, it was just the Shape showed Table not in Sync because the Defaults didnt fit, as soon as I fixed it, it went green instantly.

2019-03-14_0915


(Bart Elia) #7

Oh I do remember that. That’s what I get for late night e10Help review.

Did you ever get a ticket on that? I know we had a story about improving tool tips on the Yellow button or something from a ways back but since I have not been day to day on E10 I’ll have to pester the folks in charge for current thinking.


(Jeff Gehling) #8

@hasokeric this solution worked great for me! I pitty the person who has 200-300 custom fields on a table tho haha :wink: . unless paste insert after modifying in excel works too.


(Greg Celentano) #9

Support could not figure this out for us either. They gave us the old “its not you, its me” speech. They sent it to development.

Thanks for posting we will be trying this out.


(Greg Celentano) #10

FYI this worked for us.

This issue made us uneasy on what was wrong with the system. Mostly being that seeing a message that says something is not in sync can be concerning to some users. When Epicor says that its “probably OK” with no documentation backing that claim. My group was concerned there was a bigger underlying problem.

There was a KB article on this for the same issue but the resolution was kind of a cliff hanger.