Remove a sort on a dashboard (restore the BAQ's sort)


(Calvin Krusen) #1

While developing a dashboard, I sorted one of the columns by clicking its header, and now the dashboard defaults to using that as a sort, overriding the sort order in the BAQ.

image

How can I remove that sort at the dashboard level, so the BAQ one is used by default?

FWIW - The BAQ has several levels of the sort, so just clicking the column I want as the default to sort by, doesn’t cut it.

I’ve also gone into developer mode and tried all the various “Reset Layouts…” under Tools->Layouts, but with no change.


(Doug Oswald) #2

Right-click, clear grid sort. Works in 9.05.
image


(Calvin Krusen) #3

Where exactly did you right click?

Clicking in the grid, column header, or grid title, only give me:
image

Is the screenshot you provided from a run-time or assembly dashboard?


(Calvin Krusen) #4

I opened a different dashboard, an Updatable one (which have to be deployed as Assembled) and that shows the Clear Grid .

I don’t usually create Assembled dashboards unless they are updatable.


(Doug Oswald) #5

Sorry, should have mentioned it was deployed.


(Dave Dortman) #6

Open the dashboard, arrange columns and sort as desired. Then go to Tools > Layouts > Save Layouts As Default. Redeploy the dashboard and all should be good!

Dash


(Calvin Krusen) #7

When I open the dashboard in Developer mode, it still shows that column as sorted. So doing the “Save Layouts As Default” appears to save that sort as well.

During the Deploy process, when I test the dashboard, it gives me the option to clear the grid sort. Which I do. But the eventual deployed dashboard still has the sort.


(Brandon Anderson) #8

what happens if you go re-save your BAQ?


(Calvin Krusen) #9

I edited the BAQ (just added an extra column) to make sure it really changed, and it still launches with the grid sorted.

Launched by opening “Dashboard” and then loading the specific dashboard.

I can clear the sort on my personalized view of the deployed dashboard, but if I launch the “base only”, it shows the grid sort. I don’t want every user to have to do the Clear Grid sort thing. I should be able to have that cleared in the base configuration.


(Bill Anthony) #10

@ckrusen – Greetings, Calvin.

I had this exact issue on v10.1.400.14 (not sure which version you are on currently) and submitted a case to Epicor Support on 2017-08-14. After about 2 weeks of analysis, Epicor came to the conclusion that this was a development issue, as depicted here in the copied case notes from the support rep:


I tested the current baseline Epicor 10.1.400.33 and 10.1.600.9 software systems and duplicated the problem. Since this is no longer a Support Issue, but now a Development Problem, I created a New, Development Problem Case.

The Problem Case Number is PRB0187996 and has the following Description:

PROBLEM DESCRIPTION: When a Dashboard is created with a Tracker View, selecting a Column in the Tracker View will cause that Column to be sorted. If this was done be accident, there is no way to un-do the Sort, as Grid Option “Clear Grid Sort” is not available.

PROGRAM ID: Dashboard

EXPECTED BEHAVIOR: Clear Grid Sort should be an available Grid Option, just like it is in Base Grids.


Apparently, this issue exists up to, at least, v10.1.600.9.

I did not follow up on PRB0187996, so I do not know what the current disposition might be at this time.

Hope that helps with some background.


(Calvin Krusen) #11

Thanks. I can stop beating my head against the wall trying to do something that seems like it should be pretty standard.

P.S. we’re on 10.1.400.23


(Bill Anthony) #12

Hey - at least you know there’s someone out there who’s still working in an earlier version that what you have in your environment… :confounded:


(Calvin Krusen) #13

FWIW - Exporting the Dashboard and re-importing it doesn’t work. The sorted column is included in the dashboard definition file.

I found the following in the dashboard definition,

<a1:UltraGridBand id="ref-12" xmlns:a1="http://schemas.microsoft.com/clr/nsassem/Infragistics.Win.UltraWinGrid/Infragistics4.Win.UltraWinGrid.v12.2">
	<Key id="ref-14">Results</Key>
	<Columns href="#ref-15" />
	<SortedCols href="#ref-16" />
</a1:UltraGridBand>

After removing the line

<SortedCols href="#ref-16" />

And re-importing, it looks like it is fixed.

Note that I only did this on the test environment, as I’d not import manually edited exported dbd files

FTR - the above code is XML within an XML file so it actually looks like:

....&lt;SortedCols href="#ref-16" /&gt;......

(Michael Cho) #14

This trick works on 10.1.500. Try Show Group By using the sorting column and then remove Group By.


(Chris Conn) #15

Are you willing to make a customization and use code to fix it?

var ourGrid = (EpiUltraGrid)csm.GetNativeControlReference("your grid guid");
var ourGridSortCols =  ourGrid.DisplayLayout.Bands[0].SortedColumns;
ourGridSortCols.Clear();