Random reports popup for wrong user


(Roger Leclerc) #1

Curious to see if anyone has experienced this specific issue before.

We’ve had an issue where random users get a popup of reports that they didn’t run as soon as they launch their Epicor session.
We’ve had our task agent lockup for printing and cleared the queues. A couple of days after clearing this we’ve had a few users report that a random general ledger report and a journal entry popped up as soon as they launched Epicor.

We’ve discussed with Epicor support and they confirm that this has happened before and it’s most likely a cache issue on our SQL server and suggested that we reboot our servers to clear this. It was confirmed that this was seen before where the next user to run a specific report would obtain a copy of an older report that failed and this is being released to their session…However it was never seen that the reports get sent to a totally random user that did not at all request/run that specific report.

Curious to see if anyone out there has ever seen such an issue?


(Ken Nash) #2

Check in the system monitor to see if there are any scheduled tasks for that user.

Make sure you have Display all Tasks selected under actions.

We have seen this happen a few times. We deleted the scheduled report to fix the problem.


(Roger Leclerc) #3

Thanks Ken, we thought of this as well and unfortunately there was nothing running under their scheduled tasks.

Still a mystery!


(Ken Nash) #4

what about a report personalization? those are stored in the database.

In a Studio see if the email is set as a default in here. That occurred once for us as well.

select * from Ice.RptDefault


(Heather Marie) #5

We have run into this in the past as well. If you take a look at the post below it should explain why this is happening and what you can do to fix it:

Quote from @aidacra in the above post:

the default option of Default will likely result in the occasional situation where userA submits report1 for print preview and userB will see it instead, as the Default setting uses only the Windows session ID of the user that submitted the request :expressionless:

So, everyone should change their Work Station method to some value that will be guaranteed to always be unique for every user–for almost everyone, Machine Name + Domain User meets that requirement.


(Roger Leclerc) #6

Thank you Heather, we’ll definitely take a look at those options.