Order Entry Ready to Process Message


(Aaron Willett) #1

Looks like this has been asked before, but there were no answers.
Does anyone know if it’s possible to suppress the message that pops up in Order Entry when you leave the “Ready to Process” box unchecked? I don’t want to default it being checked, either.
Ideally, I’d like to have it be able to be unchecked and be able to go to a new order or exit without that message coming up.

image


(Jose C Gomez) #2

Looks like it’s pretty much Hard Coded into the Form. No BPM and no Server Side Code can save you.

public bool CheckReadyToProcessFlag()
{
    if (!this.orderHedHR())
    {
        return true;
    }
    if ((bool) this.orderHedView.dataView[0]["ReadyToCalc"])
    {
        return true;
    }
    if ((bool) this.orderHedView.dataView[0]["LOCHold"])
    {
        return true;
    }
    bool flag = false;
    switch (EpiMessageBox.Show(EpiString.GetString("readyToProcessQuestion"), string.Empty, MessageBoxButtons.YesNoCancel))
    {
        case DialogResult.Yes:
            flag = true;
            this.orderHedView.dataView[0]["ReadyToCalc"] = true;
            if (!this.Update())
            {
                return false;
            }
            return flag;

        case DialogResult.No:
            return true;
    }
    return flag;
}

So short of meeting one of the first 3 criterias above… You are SOL.

  1. No Header Record
  2. Already Set
  3. LOCHold = true (WTF is LOCHold?

(Aaron Willett) #3

LOC… Letter of Credit? Maybe?

Also… That sucks, but is what I expected.


(Jose C Gomez) #4

Yup Letter of Credit you are correct! Sorry bud


(Randy Stulce) #5

Welcome to the club my man.


(Aaron Willett) #6

I don’t like this club. Can I opt out? Lol


(Mark Wonsil) #7

From an Epicor behavior standpoint, the two things I’ve notice (and there may be more) but your booking records are not written and/or your tax calculations are not done until you check that box.

Mark W.


(Aaron Willett) #8

@Mark_Wonsil, understood. We don’t use the bookings records for anything and we calculate tax once for sending out the acknowledgement. It’s not uncommon for us to have orders pushing 100+ lines and if you leave it checked, any change made on any line recalcs the tax which takes upwards of 4 minutes for an order that big. We’d like to move away from it being checked and only checking it when a tax calculation is needed, then unchecking it.


(Monty Wilson) #9

Dear Aaron,

Check this out in Company Configuration:

I don’t think it was there in 10.0 because I specifically looked for it and finding no such control, I ended up installing Dialog Devil on all inside sales computers. My system here is 10.1.600 and it has the option; I think it will do what you need.

I should also mention that the wording of the help topic may imply that the flag only affects Avalara tax customers but alas, Epicor enforces the “warning” regardless.

Best,
…Monty.


(Aaron Willett) #10

Hi Monty,

We don’t want to use that as that will, by default, cause new orders to have that box checked.
We don’t want to have it checked and we want to suppress the message that asks if we want it to be (because we don’t).


(Monty Wilson) #11

In that case, Dialog Devil was the best option I found. It’s shareware from a guy in the UK and we used it to click “No” automatically on the salespersons’ computers every time that box appeared. The user either doesn’t see the box, or sees it briefly appear and disappear. The program doesn’t even lose focus in Windows, at least in Windows 7 which is what we were using at the time.

Because the company didn’t have Avalara, and that’s the only thing the check box controls, we honestly didn’t care if it was Yes or No, just didn’t want to hassle with the box on every order. Hope you find a better solution.


(Randy Stulce) #12

Mark, we have some orders (from a certain big retail chain) with 4000+ releases. Epicor support gave us a setting for the local client’s SysConfig file that worked for us in both E10.0 and E10.1. This works for both Sales Order and Customer screens.

NOTE: Use at your own risk, backup your database first, test on a copy of your database, etc and other caveats apply :wink:

The performance problem you are having add a Ship-To to a Customer can be addressed by setting a value in the SysConfig file. Under UserSettings in the sysconfig, add a node TreeExpandIndicatorThreshold value=“100”

This will tell the tree control to not loop through checking for children/grandchildren etc. if the parent entity has more than 100 nodes in the tree. This will speed up both initial data retrieval and data refresh after an update.

<userSettings>
   <TreeExpandIndicatorThreshold value="100" />
</userSettings>