No Data appearing in added Table


(system) #1

Isn’t PartLot a table already included in the original ARForm report Data Definition?

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of SimsTrak Consulting
Sent: Monday, November 04, 2013 2:36 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage] No Data appearing in added Table

 

 

First question, why are you creating a relationship between OrderHed and PartLot?  It would seem to be OrderHed to InvcDtl.

 

Second, you probably don’t need to create a new relationship.   On the InvcDtl table, there are Linked Tables, one of these is called “OrderNum”  (why they don’t use the table name for the linked table – you got me).  Make sure that table is picked, then go to the Report Table -> Linked Tables -> Description Fields and pick the fields you want.    In your XML, these OrderHed fields don’t show up under a separate OrderHed table, instead they are shown as fields within the InvcDtl table.  For example, the PONum field from OrderHed would be the “OrderHed_PONum” field on the InvcDtl table.   Confused yet?

 

Kevin Simon

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of ingelstan@...
Sent: Monday, November 04, 2013 2:17 PM
To: vantage@yahoogroups.com
Subject: [Vantage] No Data appearing in added Table

 

 

In Report Data Definition, i added OrderHed table to ARForm, first creating a duplicate report. I created a relationship from OrderHed to PartLot.  When I bring in the table to the crystal report for there is no data appearing for any of the included fields.

 

Does this mean i need to create another relationship?? Anybody else run across this before?

 

Thanks,

Stan


(system) #2

First question, why are you creating a relationship between OrderHed and PartLot? It would seem to be OrderHed to InvcDtl.

 

Second, you probably don’t need to create a new relationship.  On the InvcDtl table, there are Linked Tables, one of these is called “OrderNum” (why they don’t use the table name for the linked table – you got me). Make sure that table is picked, then go to the Report Table -> Linked Tables -> Description Fields and pick the fields you want.    In your XML, these OrderHed fields don’t show up under a separate OrderHed table, instead they are shown as fields within the InvcDtl table. For example, the PONum field from OrderHed would be the “OrderHed_PONum” field on the InvcDtl table.   Confused yet?

 

Kevin Simon

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of ingelstan@...
Sent: Monday, November 04, 2013 2:17 PM
To: vantage@yahoogroups.com
Subject: [Vantage] No Data appearing in added Table

 

 

In Report Data Definition, i added OrderHed table to ARForm, first creating a duplicate report. I created a relationship from OrderHed to PartLot.  When I bring in the table to the crystal report for there is no data appearing for any of the included fields.

 

Does this mean i need to create another relationship?? Anybody else run across this before?

 

Thanks,

Stan


(system) #3

Sometimes, and I mean sometimes, the relationship type I leave blank. I think you can use outPut, definition or nothing.  Seems to work better for me when I leave that blank. 

 

Miguel A. Santillan

Compass Manufacturing Systems

510-661-6666  Office

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of SimsTrak Consulting
Sent: Monday, November 04, 2013 1:36 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage] No Data appearing in added Table

 

 

First question, why are you creating a relationship between OrderHed and PartLot?  It would seem to be OrderHed to InvcDtl.

 

Second, you probably don’t need to create a new relationship.   On the InvcDtl table, there are Linked Tables, one of these is called “OrderNum”  (why they don’t use the table name for the linked table – you got me).  Make sure that table is picked, then go to the Report Table -> Linked Tables -> Description Fields and pick the fields you want.    In your XML, these OrderHed fields don’t show up under a separate OrderHed table, instead they are shown as fields within the InvcDtl table.  For example, the PONum field from OrderHed would be the “OrderHed_PONum” field on the InvcDtl table.   Confused yet?

 

Kevin Simon

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of ingelstan@...
Sent: Monday, November 04, 2013 2:17 PM
To: vantage@yahoogroups.com
Subject: [Vantage] No Data appearing in added Table

 

 

In Report Data Definition, i added OrderHed table to ARForm, first creating a duplicate report. I created a relationship from OrderHed to PartLot.  When I bring in the table to the crystal report for there is no data appearing for any of the included fields.

 

Does this mean i need to create another relationship?? Anybody else run across this before?

 

Thanks,

Stan