New Suppliers Not automatically Approved

customization

(Brendan Woodell) #1

I’d like to set Supplier Entry to NOT have the Approved box checked automatically when creating a new supplier. Yes, I can do this after the fact in a BPM, but from a UX perspective it’s sloppy. I’d rather it look the way it performs so I don’t get questions like “Why does this uncheck every time?”.

In a customization, I can make another checkbox and replace the base Approved checkbox. But for something so small, that seems silly. There’s got to be a way to control the existing checkbox so it just isn’t automatically checked when we create a new Vendor. I tried getting the checkbox GUID and controlling that, I also tried setting the DataView’s Approved field to false when EpiNotify.AddRow fires. No effect for either.


(Jose C Gomez) #2

As simple as a post processing BPM on Vendor.GetNewVendor

No custom code simply use the Set Field and set Approved = false

BPM Attached for 10.1.600
supplierUnApproved.bpm (18.6 KB)


(Brendan Woodell) #3

Dangit. I did try something with Get New and it didn’t work. Probably over-thought it. Thanks Jose, as always.