Network routing

tax-connect

(Calvin Krusen) #1

We’re still having issues with Tax Connect connectivity. When I run the Test Connection in Company Config, it fails about 20% of the time.

Some crude diagnostics I’ve tried include:

  • Pinging the Avalara endpoint (avatax.avalara.net)

    • Returns the IP, but no ping response. (This is not unexpected)
    • The IP varies from run to run, and appears to be on Amazon Web Services
  • TCPView (A crude viewer of active TCP connections) on App Server.

    • When the Test connection fails, a connection between the App Server and Avalara is shown, but with the connection status of SYN_SENT. This indicates the remote computer(Avalara) never responded.
  • Tracert from App Server to avatax.avalara.net

    • Tracert ends (after taking the full default 30 hops ) prior to reaching avalara
    • Increasing the max hop count to 100, and the trace ends prior to reaching avalara
    • The first two hops in the trace are IP addresses owned by us. But after that, they all appear to be other companies (sgns.net, quest.net, centurylink.net, etc …)
  • Tracert from my home PC (via my home ISP) to avatax.avalara.net

    • Tracert reaches avalara in just two hops

My questions:

  1. Is it odd that the IP address of a URL is constantly changing? I understand that there have to be many IP’s to handle the traffic, but shouldn’t there be some thing like DHCP that remembers the address for a client? And does my local system remember the IP in its DNS cache, such that successive uses of the same URL would want to use the same IP add?

  2. Am I barking up the wrong tree when I think the tracert should only be a couple of hops once It’s past my fire wall (like I see when tracing from my home ISP)

  3. Is there a way to improve the connectivity to a remote host whose IP is constantly changing?


Is Avalara part of Epicor?