EpiTimeEditor Blank Title 59214


(system) #1
V9.05.702A


I am working with support but wanted to see if anyone has used a EpiTimeEditor in 9.  I am having a issue where when I bind OrderHed.Number02 to a EpiTimeEditor it causes an issue where it seems to be causing the form/table to see a change even if a change does not occur.

He is an example
I open a Closed SO and just clicking into a field on the Line Tab immediately causes E9 to present a message box asking to Save Changes. This happens in open orders also. Clicking in the Header does not cause this, but linking to Entry from SO Tracker also causes this to occur.

I remove the binding from the control and the issue no longer happens.  

As I stated I worked with support and in their Base of SO Entry it happened also.  So I feel that there is either something wrong in the control's class or we are not binding it to the proper DB field type in E9.  We tried a Date field but then you could not even click over to another Tab.

This did work in V8 but obviously E9 is a different beast.

Thanks for any input

Scott



(system) #2
I don't understand why they dont have a variable for the EpiTimeEditor.

Say if I have 2 fields on a custom form that are TimeEditors (hh/mm
(AM/PM))

What do I set the Datasource/Datafield to for these variables so that
they will be saved with all the other information on the form?

(system) #3
In V8 I would think you would bind the time editor control to a
UserDate field....

--- In vantage@yahoogroups.com, "dub554" <mbarron@...> wrote:
>
> I don't understand why they dont have a variable for the
EpiTimeEditor.
>
> Say if I have 2 fields on a custom form that are TimeEditors (hh/mm
> (AM/PM))
>
> What do I set the Datasource/Datafield to for these variables so that
> they will be saved with all the other information on the form?
>