Epicor error: Object reference not set to an instance of an object


(Mark Rowley) #1

Epicor version 9.05.701

When opening Epicor, this error occurs:

Error Detail

Object reference not set to an instance of an object.

Stack Trace

at Infragistics.Win.UltraWinGrid.UltraCombo.get_CheckStateColumn()
at Infragistics.Win.UltraWinGrid.CheckedListSettings.get_IsValueProvidedByCheckedItemList()
at Infragistics.Win.UltraWinGrid.UltraCombo.set_Text(String value)
at Epicor.Mfg.UI.FrameWork.EpiUltraCombo.Data_Notify(EpiDataView view, EpiNotifyArgs ar)
at Epicor.Mfg.UI.FrameWork.EpiViewNotification.Invoke(EpiDataView view, EpiNotifyArgs args)
at Epicor.Mfg.UI.FrameWork.EpiDataView.OnEpiViewNotification(EpiNotifyArgs e)
at Epicor.Mfg.UI.FrameWork.EpiDataView.Notify(EpiNotifyArgs args)
at Epicor.Mfg.UI.FrameWork.EpiDataView.SetChildFilterAndNotifyChildViewWhenNoCurrentRow(EpiDataView childView, EpiNotifyArgs args)
at Epicor.Mfg.UI.FrameWork.EpiDataView.SetChildFiltersAndNotifyChildViews(EpiNotifyArgs args, Boolean forceIt)
at Epicor.Mfg.UI.FrameWork.EpiDataView.Notify(EpiNotifyArgs args)
at Epicor.Mfg.UI.FrameWork.EpiDataView.SetChildFilterAndNotifyChildViewWhenNoCurrentRow(EpiDataView childView, EpiNotifyArgs args)
at Epicor.Mfg.UI.FrameWork.EpiDataView.SetChildFiltersAndNotifyChildViews(EpiNotifyArgs args, Boolean forceIt)
at Epicor.Mfg.UI.FrameWork.EpiDataView.Notify(EpiNotifyArgs args)
at Epicor.Mfg.UI.FrameWork.EpiTransaction.NotifyAll()
at Epicor.Mfg.UI.FrameWork.EpiBaseForm.setupUIElements()


(Monty Wilson) #2

Mark, we have a script called “clear stuck E9” which we must run now and then; possibly it could help? (attaching a BAT file doesn’t work; text of the file is shown below)

cd C:\Users[YourUN]\AppData\Roaming\Microsoft\CLR Security Config\v2.0.50727.312

Del security.config.cch

cd C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG

Del *.cch

pause


(Ken Adams) #3

Hi Mark,

Is this a new computer? I seem to recall this being an issue that is resolved by checking the compatibility setting on the properties for the Epicor Icon on the desktop.


(Mark Rowley) #4

Yes it’s a new pc

Interestingly…it works fine with an admin windows login.
But not with the user login


(Mark Rowley) #5

I’ve deleted the files but no joy.

It’s bizarre as I mentioned in my last reply that if I sign in with an admin windows login but still using the same users epicor login credentials it works fine.
But it falls over if the user logs in to windows as themselves and then into epicor themselves


(Ken Adams) #6

Hi Mark,

If you look at the properties for the Epicor Icon, check the compatibility.


(Greg Payne) #7

Check that Domain_Users has modify permissions on the Program file\Epicor and ProgramData\Epicor directories. If we don’t add this then IT can run Epicor, but users can’t :frowning:


(Ken Adams) #8

Does it fail regardless of which user tries to log in?


(Simon Hall) #9

Check the location of your Epicor temp folder (you can define this in the mfgconfig.sys) I think by default is c:\programdata\Epicor. If you installed as an admin user and the permissions are not set to modify as Greg mentioned it will break. Is the user a member of local admins on the PC? If that is your policy and that step was missed during the setup of the new PC/User then you will see this problem.

Hope that helps.


(Jose C Gomez) #10

Does this user have setup any auto start applications? Those errors look to be coming from notifications on a DataView which shouldn’t happen until you launch something.
Check if they have some auto launch settings. I think you can hold down SHIFT? while Opening Epicor to over-ride auto launch… is it shift @aidacra? Or am I mistaking Epicor with something else… I swear there’s a keyboard over-ride.


(Jose C Gomez) #11

Yup just tested Shift will over-ride. Try launching Epicor logging in with holding down Shift.


(Mark Rowley) #12

Update:

  1. Tried right clicking on the epicor shortcut, selecting properties and it looks identical to the screenshot above.

  2. Tried holding down SHIFT whilst opening epicor and the same thing occurred.


(Jose C Gomez) #13

Maybe a corrupted windows profile. Try logging in as admin and deleting the users profile?

-Jose


(Greg Payne) #14

Did you check the programdata and program files permissions?


(Andrew Saldivar) #15

I’m w/the consensus on this one. I suspect folder permissions or domain group membership.
Any chance you can elevate this user to “Local Admin” and see if the problem goes away?
Othws, with the user logged in, see which of the Epicor folders the user cannot view in Windows Explorer, then make sure the user has domain access to the Epicor server by navigating to the server in Win Explorer.

I didn’t see a reference to whether this is an existing (or new) user. Perhaps you have an active directory group that contains Epicor authorized users and didn’t add this user to that group?


(Mark Rowley) #16

Apologies for the delay.

I’ve got a bit of an update on this.

If the user logs in to epicor through Remote Desktop Connection - it all works fine.
If he tries “locally” it doesn’t.


(Sue Nielsen) #17

My guess is Jose’s suggestion is the issue…corrupted Windows user profile. We just had it happen yesterday to one of our users. Epicor worked fine if we logged him onto the laptop as another user and he used his own Epicor login. Epicor bombed if he uses his own Windows login on the same laptop. (We’re on E9)


(Mark Rowley) #18

All,
apologies for the delay…below is the fix

FIX:

This is in regards Object Reference error message reported in quote entry, please try the solution below.

SOLUTION:
This is a Windows 7 setting that appears to affect the way the Epicor 9 application window is opened. I imagine the default setting for Windows was changed on the workstation PC somewhere along the way and being it is such a basic OS setting.

Before you start the steps of changing this Windows setting, please save and exit any work and programs you have open on your PC because a system log off and restart will be needed after the change to take effect.

1-Start by Opening the Windows Control Panel and select the Display option.
2-Your Current setting is likely set to the [x] Medium - 125% This setting will not be the preferred setting if you are going to use Epicor 9 on this PC.
3-Please Change the setting to [x] Smaller - 100% (default) and Press the [Apply] button to save the change.
4-The following message will appear. Choose Log off later - because you will be doing a restart of the PC in the next step instead of a log off.
5-Restart the PC.
6-When the PC is rebooted, re-launch your Epicor905 shortcut.
7-Branch open Sales Management > Quote Management > General Operations > Opportunity Quote (or whatever screen/form was displaying the error) The Opportunity Quote form will now open correctly and not give any error.
8-If you need to change the display so that the user can see the icons and programs opened, the method you can use in Windows 7 is to adjust the Display resolution

Control Panel > Display > Change Display settings (on the left side of panel) Change the appearance of your display> Resolution selection window. Using the slide bar, move the resolution from 1280x1024 down to 1024x768 Click the Apply button, click the Ok button, close the display button out. Launch Epicor905 - Test Quote Entry… Quote entry will now open normally.

Adjusting the resolution is the only way around this issue at the moment, you need to leave the desktop display at 100% (default) 125% & 150% do not work.

This should fix the issue. Please update me once you tested.