Epicor DUU


(Jose Fernandez) #1

Hello everyone! I been banging my head for the last month and still stuck at the same spot. Hopefully some light can be shed!

i am doing an upgrade from Vantage 8.03.409C to Epicor 10 through the DUU utility guide.

I backed up my prod db to my test (SQL) then i created a new server (OS:2008R2). I installed SQL 2008R2. I installed progress 10.2a as a 32 bit application. I then installed epicor 9.05 wiith the DUU.

Everything as the guide states. Then i open the DUU utility and select my backup db file and my uom file, i select the current server to install the upgrade DB. When the screen ask me to select an sql instance, i select the current server instance and it just says that the Instance is not compatible. Support told me to restore the backup db manually.

I restored the DB manually, then i ran the DUU again and skipped the restore of the DB. I followed the guide and ran the schema change. The schema change ran and came back with 0 errors. i start the app server through progress tool (i was able to open progress explorer through changing the Java binary from 1 to 0 since this is a 64 bit server). Then i go to open the 904 admin tools and i get the error

Schema holder does not match database schema – file dbo.cntgver field v_803500

i re run the schema change but it states that no schema change required with this message:

Database level:8.03.400 program Level: 9.04.508 No Schema Changes required

Support is looking into this but i am in the same spot for a month. Can anyone who went throught the upgrade process seen this error? or any hacks that are not included in the DUU guide. I have looked in the forum but cant find anything.

Any guidance will really be appreciate it! Thank you so much!

:PS i have started over more than 4 times, trying to have my SQL on a different server than my application and i just get stuck on the same step.


(Jose C Gomez) #2

Have you considered the epicor upgrade services they are much faster and more efficient than the DUU?

-Jose


(Jose Fernandez) #3

Thanks Jose! I contacted them to see what they would quote me, but i thought i could upgrade the DB following the guide. They purposely left the special sauce on the guide because i run into issues on every step not mentioned in the guide!

did everyone just used those services upgrading their DBs? I know that from vantage to E9 is the real headche from different post i have read.


(Jose C Gomez) #4

No, I’ve done it using the DUU works fine. But their cloud service is amazing I was involved in the early stages of beta testing and I can attest it is a fantastic product written by the amazing guys from the .NET IT team. Well worth the money and not very expensive at all.
The amount of time saved alone will be worth it.

But DUU does work …it’s just painful


(Jose C Gomez) #5

I recommend you to to 410 first from there use the DUU to 9.05.702


(Jose Fernandez) #6

Thank Jose! Will look forward to hearing from the their team!

In the meantime, i will try your suggestion. Thank you!


(MIGUEL S.) #7

I dont know the DUU, but I used Epicor Migration Services as well, after I was trying to upgrade from Progress 702A to E10.

I paid their $2k for 3 passes. I did a cloud transfer to their server, and they started to convert. There were some errors that occurred and they fixed them on their side. 36 hours later I had a E10 version of my progress DB on my sql server. Their conversion tool has come a long way.


(Jose Fernandez) #8

i have contracted Epicor Services. Thank you all!

Miguel, how big was your Db? When reviewing the upgrade process, was there any step where it didnt seem to update/ move for hours? (the duration was on the same # as well as %?)

Thank you

Jose


(MIGUEL S.) #9

Database currently is about at the time was 60GB. 46GB of data and 14GB of index it states.

During my Cloud Worker and Cloud Conversion. But that was probably because I had an issue, then they fixed it and I didnt get a chance to see the progress anymore because when I knew there was an error. Email was sent to me. I didnt expect them to fix it so quickly, but they started the process again and before I new it, my DB was done.


(Jose Fernandez) #10

Thanks! Miguel! Thats good to know!

the run conversion has been on 88% and 42 mins for 2 days now. Epicor says its still running maybe it takes longer from 8.03.409C instead of 9.05.702A. Will give it a day or two before i ask them again!

Jose


(MIGUEL S.) #11

Thinking the same thing, you have a few extra layers with 8.XX. It will error out when it fails and you should get an email indicating so. Good Luck.

image


(Jose Fernandez) #12

Great! Havent gotten any errors or email yet. So thats good news!

Jose