Epicor crashes after adding custom button to scheduled shipments dashboard


(Mason Zeimet) #1

I’ve tried twice to add a button to the scheduled shipments dashboard. After saving the customization, closing, and clicking its icon, the “Downloading from Database” UI pops up and that’s where everything stops. Epicor stops responding and I have to task manager close it each time. I think it’s doing something incorrect with the XML, because when I imported the Live server’s customization, the long line of XML created from the button is gone and things work fine. How can I add a button without it crashing?


(Jason Woods) #2

I have found it better to deploy the dashboard and then add your custom buttons to the DLL version.


(Chris Conn) #3

I second Jason’s advice. If you’re gonna customize a dashboards, compile to an assembly first. Then place your customization of the the assembly in the menu.


(Simon Hall) #4

I third that. :slight_smile: Remember if you want to quickly create a menu item from a dashboard assembly:

  1. Deploy your dashboard as an assembly. (click on add to favorites)
  2. Log into classic mode (Not sure if you can do this in the modern shell)
  3. Select the menu where you want to put the assembly
  4. Click on favorites
  5. Click on Dashboard Assemblies
  6. Click Developer mode
  7. Right mouse click on the dashboard assembly in question and drag into the menu on the right

It should prompt you and then you should have a new icon for the dashboard in the menu, no setting up, but the security ID will be get set to a default value so you may want to change that

use classic mode, select the menu you want to put the menu item for the dashboard. got to favorites select dashboarddeploy a dashboard to menu.mp4 (911.4 KB)