Disable predictive search when creating something (Also, bug on the predictive window)

predictive
search

(Steven Simard) #1

Hi,

In the ‘Part’ window, I added a predictive search for the PartNum field so I can retrieve easily a part. However, when creating a new part, the predictive search still works. The main problem is that this small window doesn,t fade until I select an option. I would want it to disappear once I lose focus on the field.

Any way to fix this bug?

Thanks


(Brandon Anderson) #2

It will time out, but it takes a looong time.

I too would be interested in figuring out how to control that box a bit better.


(Toby Lai) #3

I got some notes from Insight a while back for configuring the predictivesearch.

I am not sure if you can disable it for new parts.

There are two fields in the sysconfig file (Should be under the client installation folder and a subfolder called config)

Open the file with notepad and find the key related to PredictiveSearch.

The values are in ms.

<PredictiveSearchKeyPressDelay value="1000" />
<PredictiveSearchPopupFadeDelay value="2000" />

But that was for 10.0.7.4, not sure if they have changed since.


(Steven Simard) #4

Thanks, the values are still there. I’ll try to change them soon and test it but it was set to 15000ms so a 15 seconds delay to fade away


(Brandon Anderson) #5

It’s in the config editor too. Works great!


(Steven Simard) #6

Even better, thanks. Unfortunately, I don’t know how to access this editor since I didn’t configured it myself

Edit: Got it. In my folder, there’s an .exe application called ConfigEditor and then you open the sysconfig file.