Decimal Type UD Field Causing UBAQ Exception


(Tom Hulbert) #1

I have a UD Checkbox on the JobHead table that I am using it on an updatable dashboard. We have the ‘Prevent Changes’ to engineered jobs box checked in company configuration. Prior to 10.2 I was able change the UD checkbox on my dashboard and save it without issue. After we upgraded, when I try to save my changes on the dashboard, the entire row turns red and a tooltip displays stating, “Update not allowed, Engineered and Prevent Changes.” Udash%20Error

This doesn’t make sense because when I read the help documentation it clearly states that I should be able to save the change.

Is anyone else experiencing this issue? Am I missing something somewhere with my setup? I opened a ticket with Epicor support and received a call from someone saying that if it doesn’t work now then the dev team must have changed something. I asked him why wouldn’t it have been documented somewhere and why does the latest Help documentation contradict his answer, but received the same response. I opened a second ticket and so far all I’ve head is that the Dev team didn’t change any functionality related to my issue. The ticket is still open, but I’m not holding out much hope.


(Pierre Hogue) #2

Sorry to ask… but did you recompile your dashboard? test in devmode?

Pierre


(Tom Hulbert) #3

Yes, I have re-deployed the dashboard through dashboard maintenance and verified customizations through Customization Maintenance.


(Pierre Hogue) #4

When I copy the Udb from one env to another I often had to open and test
the uBAQ and then save. At least I know the BAQ works with updates etc…

Then test with the dashboard…

Does your uBAQ works in design mode? (under Query designer ) ?


(Chris Conn) #5

Is there error occuring OnChange or OnUpdate? If it’s OnChange, no luck, they catch it before it even goes to the BO. If it’s OnUpdate, you can write special handling to solve this.


(Tom Hulbert) #6

@Hogardy - I receive the same error when I try to save an update in the Query designer.

@Chris_Conn - The error occurs OnUpdate.


(Chris Conn) #7

So one solution would be to write your own Update BPM there. For the processing, you look at the that field and determine what needs to happen.

For example, you should be able to write the code to Unengineer/Unrelease the job… Do your stuff, then Re-engineer/Re-release

You could probably do it using visual objects in the BPM designer, I prefer code though.


(Tom Hulbert) #8

After doing a bunch of testing I’ve finally discovered what the problem is.

When I run the BAQ in Designer and attempt to update the UD Checkbox I receive this exception:

It looks like the UpdateExt BPM is trying to update something on the JobMtl table, but the Field is blank. My first thought was to remove the two UD fields that I was displaying on the JobMtl (both fields were decimal values) and low and behold the update worked. I need to display both fields on my dashboard so now my question is, why is the BPM trying to update those fields when they aren’t selected to be updated?


(Chris Conn) #9

Do you have to use update ext? Can you just use update?


(Brandon Anderson) #10

Is this box checked? What happens if you uncheck that box?


(Chris Conn) #11

If you uncheck it, it means the system will not attempt to update any fields in that table.


(Brandon Anderson) #12

I figured that, what I want to know is does the error that he is seeing go away…


(Tom Hulbert) #13

@Chris_Conn - UpdateExt is the method that the system defaults to when I select the JobEntry BO for BPM Update Processing.

@Banderson - I tried unchecking the JobMtl box, but when I click Get List on the analyze tab the system checks the box again.