Customizations not visible in menu maintenance after changing each to "All Companies"


(Mason Zeimet) #1

My company is upgrading from 10.1.400.x to 10.2.200.8. As is common with others, several customizations weren’t showing in menu maintenance. I ran a query

update Ice.XXXDef 
set Company=''
where typecode='customization'

update Ice.XXXChunk
set Company=''
where typecode='customization'

to change Company to “All Companies,” and now some customizations that were visible before the query are now not showing in menu maintenance.

Creating new customizations with “All Companies” or with my company name won’t make them show. I’ve also tried following what many other posts say about customizations and menu maintenance but none are working. Any ideas?


(Nathan your friendly neighborhood Support Engineer) #2

Do you have any customizations that do show up in the Menu Security? What is the company value on xxxdef/xxxchunk for those customizations?


(Mason Zeimet) #3

The company is blank for all customizations, and the “All Companies” checkbox is selected for each.

Are you asking if any customizations show up in the Menu options in the Security\Detail tab in menu maintenance? If you are, then yes, otherwise I’m not sure where you mean; I’m still new to Epicor.


(Chris Conn) #4

Do you which ones are missing - I know we found a bug where a few form names were changed, which causes them not to display anymore.

SelectSerialNumbersEntryForm was one of them


(Brandon Anderson) #5

Engineering work bench has a bug where no customizations will show up. I have a ticket in on that, but you should call it in too if you have the same problem.


(Mason Zeimet) #6

I think these are all that aren’t showing:
Vendor Entry - only SupplierTracker is selectable
Receipt Entry
Receipt Tracker
Purchase Order Tracker
Engineering Workbench - only Method Tracker is selectable

I looked at the arguments in the database for PO Tracker, and -formName POTrackerForm is there from having solved this issue previously.


(Brandon Anderson) #7

Call in a ticket. This needs to be fixed soon, I already have one in, but we need more people to report it.


(Mason Zeimet) #8

@Banderson @Chris_Conn I submitted a case with Epicor and they have a hot fix for this (Brandon maybe you already got this). For anyone with this issue in Menu Maintenance, refer to issue PRB0204581 when submitting a case to Epicor and hopefully you’ll get the hasty response with the patched dll.


(Brandon Anderson) #9

I do not have the hot fix. I am following PRB0204581 for customizations not showing in engineering workbench and there is no mention of the hot fix there. I’ll have to contact service.


(Mason Zeimet) #10

I may have replied too soon. After submitting that the hot fix worked, support emailed back that my case was connected with the open problem PRB0204581. The number I mentioned before must be an identifier for the actual file for the hot fix. Sorry about that. But you should be getting that file soon enough.


(Mark Langston) #11

Just ran into the same problem, but found the customizations were visible in our Pilot DB which was just upgraded to 10.2.200.13 from 10.2.200.11 in SaaS. Live DB is still at 10.2.200.11 and can’t see the customized forms in Engineering Workbench.


(Mason Zeimet) #12

I just looked, and that fix was rolled out to everyone with 10.2.200.12.