Custom DLL Not Found - Same time in Live, Pilot and Test


(Mike Watkinson) #1

I have an assembly dashboard assigned to a menu item in Live. Test and Pilot are both clones of Live from a time after the dashboard was deployed. We recently got an error when launching the dashboard from the menu in live which said the dll could not be found. See below for text. I then went into Pilot and Test, same menu item, same error.

Trying to get it working, I cleared client cache, nothing, then I re-deployed the dashboard in Pilot. Tested the menu item in Pilot and it worked. The wild part is, when I went into Live to do the same, the dashboard can launch from the menu just fine.

We are Single Tenant / hosted and our users run Epicor from a remote session / parallels RAS from a terminal server.

Has anyone seen anything like this or have any ideas on what is going wrong? It is leaving me feel a bit exposed as our dashboards in live are going down unexpectedly.

Error Detail

============

Message: Cannot access this menu item: GPC Revenue Tran Detail

Inner Exception Message: The assembly ‘C:\ProgramData\Epicor\XXXXX-e10-a1-808\3.1.600.0\1001\shared\CustomDLLs\Ice.UI.App.GLSalesDetail.dll’ could not be found.


(Brandon Anderson) #2

I see that when I have different versions of the same thing in pilot and production. This is the workaround that gets everything that the clear cache doesn’t