Com port customization - need some help


(system) #1

Hmmm.  I am getting further.  We also had code to update the bins to match the quantity (don’t ask why) and that seemed to be the main cause of the issues.  I commented out that code and the OK button now works, but we have to manually type in the bins (currently in live, we have the customization to update the bins to match the quantity (without scale com port code).  So, I need to try to figure this part out too.

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of Jose Gomez
Sent: Thursday, October 17, 2013 7:16 AM
To: Vantage
Subject: Re: Re: [Vantage] RE: Com port customization - need some help

 

 

Yes, I would imagine if you want to save it on Part Tran you should assign to the epiview for PartTran (if available) other times what i've done is because the Part Tran table is not available I would assign it to a Charxxx in antoher one of the views and then us a Post Proc BPM to copy the fields over.



Jose C Gomez

Software Engineer

 


T: 904.469.1524 mobile


Quis custodiet ipsos custodes?

 

On Wed, Oct 16, 2013 at 10:44 PM, <kschoenung@...> wrote:

 

I am not sure that will work on this form.  Since there is a work list, I know the results go to Part Tran, but I am not sure about which view is really there as you add to the work list...The main fields show they are bound to the PartTran table, so I bound these new fields there also.  Are you suggesting that even though I assign to the epinumericeditor.value instead I need to assign to edvPartTran parttranrow("Number01") - even though it is not yet saved to Part Tran? 



---In vantage@yahoogroups.com, <vantage@yahoogroups.com> wrote:

I would assignt he value to the EpiDataView they are bound to.



Jose C Gomez

Software Engineer

 


T: 904.469.1524 mobile


Quis custodiet ipsos custodes?

 

On Wed, Oct 16, 2013 at 10:20 PM, <kschoenung@...> wrote:

 

Thanks Jose, do you know how should I be adding them to the fields?  Assign value to epinumeric editor or another way? 



---In vantage@yahoogroups.com, <jose@...> wrote:

Karen,

Depending on how the COM port values are added to the field it may behave differently.



Jose C Gomez

Software Engineer

 


T: 904.469.1524 mobile


Quis custodiet ipsos custodes?

 

On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

 

Hi all,

We have some code for reading information from a scale into Job Receipt in inventory.  The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button).  If we manually fill in the values, we are able to click OK and save the record.  Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale).  Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C

 

 

 


(system) #2

Hi all,

We have some code for reading information from a scale into Job Receipt in inventory.  The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button).  If we manually fill in the values, we are able to click OK and save the record.  Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale).  Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C


(system) #3
Karen,
Depending on how the COM port values are added to the field it may behave differently.


Jose C Gomez
Software Engineer


T: 904.469.1524 mobile
E: jose@...
http://www.josecgomez.com

     Â


Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

Â
<div>
  
  
  <p></p><p>Hi all,</p><p>We have some code for reading information from a scale into Job Receipt in inventory.  The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?</p>

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button). If we manually fill in the values, we are able to click OK and save the record. Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale). Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C

</div>
 


<div style="color:#fff;min-height:0;"></div>


(system) #4

Thanks Jose, do you know how should I be adding them to the fields?  Assign value to epinumeric editor or another way? 



---In vantage@yahoogroups.com, <jose@...> wrote:

Karen,
Depending on how the COM port values are added to the field it may behave differently.


Jose C Gomez
Software Engineer


T: 904.469.1524 mobile

Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

 
<div>
  
  
  <p>Hi all,</p><p>We have some code for reading information from a scale into Job Receipt in inventory.&nbsp; The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?</p>

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button).  If we manually fill in the values, we are able to click OK and save the record.  Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale).  Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C

</div>
 


<div style="color:rgb(255, 255, 255);min-height:0px;"></div>


(system) #5
I would assignt he value to the EpiDataView they are bound to.


Jose C Gomez

Software Engineer


T: 904.469.1524 mobile
E: jose@…

http://www.josecgomez.com
     Â


Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 10:20 PM, <kschoenung@...> wrote:

Â
<div>
  
  
  <p></p><p>Thanks Jose, do you know how should I be adding them to the fields?  Assign value to epinumeric editor or another way?<var></var> </p> <div><br><br>---In <a rel="nofollow" target="_blank" href="mailto:vantage@yahoogroups.com">vantage@yahoogroups.com</a>, &lt;jose@...&gt; wrote:<br>


Karen,
Depending on how the COM port values are added to the field it may behave differently.


Jose C Gomez
Software Engineer


T: 904.469.1524 mobile
E: jose@...
http://www.josecgomez.com

     Â


Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

Â
<div>
  
  
  <p>Hi all,</p><p>We have some code for reading information from a scale into Job Receipt in inventory.  The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?</p>

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button). If we manually fill in the values, we are able to click OK and save the record. Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale). Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C

</div>
 


<div style="color:rgb(255,255,255);"></div>

</div>
 


<div style="color:#fff;min-height:0;"></div>


(system) #6

I am not sure that will work on this form.  Since there is a work list, I know the results go to Part Tran, but I am not sure about which view is really there as you add to the work list...The main fields show they are bound to the PartTran table, so I bound these new fields there also.  Are you suggesting that even though I assign to the epinumericeditor.value instead I need to assign to edvPartTran parttranrow("Number01") - even though it is not yet saved to Part Tran? 



---In vantage@yahoogroups.com, <vantage@yahoogroups.com> wrote:

I would assignt he value to the EpiDataView they are bound to.


Jose C Gomez

Software Engineer


T: 904.469.1524 mobile

Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 10:20 PM, <kschoenung@...> wrote:

 
<div>
  
  
  <p>Thanks Jose, do you know how should I be adding them to the fields?&nbsp; Assign value to epinumeric editor or another way?<var></var>&nbsp;</p> <div><br><br>---In <a rel="nofollow" target="_blank" href="mailto:vantage@yahoogroups.com">vantage@yahoogroups.com</a>, &lt;jose@...&gt; wrote:<br>


Karen,
Depending on how the COM port values are added to the field it may behave differently.


Jose C Gomez
Software Engineer


T: 904.469.1524 mobile

Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

 
<div>
  
  
  <p>Hi all,</p><p>We have some code for reading information from a scale into Job Receipt in inventory.&nbsp; The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?</p>

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button).  If we manually fill in the values, we are able to click OK and save the record.  Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale).  Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C

</div>
 


<div style="color:rgb(255, 255, 255);"></div>

</div>
 


<div style="color:rgb(255, 255, 255);min-height:0px;"></div>


(system) #7
Yes, I would imagine if you want to save it on Part Tran you should assign to the epiview for PartTran (if available) other times what i've done is because the Part Tran table is not available I would assign it to a Charxxx in antoher one of the views and then us a Post Proc BPM to copy the fields over.


Jose C Gomez
Software Engineer


T: 904.469.1524 mobile
E: jose@...
http://www.josecgomez.com

     Â


Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 10:44 PM, <kschoenung@...> wrote:

Â
<div>
  
  
  <p></p><p>I am not sure that will work on this form.  Since there is a work list, I know the results go to Part Tran, but I am not sure about which view is really there as you add to the work list...The main fields show they are bound to the PartTran table, so I bound these new fields there also.  Are you suggesting that even though I assign to the epinumericeditor.value instead I need to assign to edvPartTran parttranrow(&quot;Number01&quot;) - even though it is not yet saved to Part Tran?<var></var> </p>


---In vantage@yahoogroups.com, <vantage@yahoogroups.com> wrote:

I would assignt he value to the EpiDataView they are bound to.


Jose C Gomez

Software Engineer


T: 904.469.1524 mobile
E: jose@...

http://www.josecgomez.com
     Â


Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 10:20 PM, <kschoenung@...> wrote:

Â
<div>
  
  
  <p>Thanks Jose, do you know how should I be adding them to the fields?  Assign value to epinumeric editor or another way?<var></var> </p> <div><br><br>---In <a rel="nofollow" target="_blank" href="mailto:vantage@yahoogroups.com">vantage@yahoogroups.com</a>, &lt;jose@...&gt; wrote:<br>


Karen,
Depending on how the COM port values are added to the field it may behave differently.


Jose C Gomez
Software Engineer


T: 904.469.1524 mobile
E: jose@...
http://www.josecgomez.com

     Â


Quis custodiet ipsos custodes?


On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

Â
<div>
  
  
  <p>Hi all,</p><p>We have some code for reading information from a scale into Job Receipt in inventory.  The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?</p>

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button). If we manually fill in the values, we are able to click OK and save the record. Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale). Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C

</div>
 


<div style="color:rgb(255,255,255);"></div>

</div>
 


<div style="color:rgb(255,255,255);"></div>

</div>
 


<div style="color:#fff;min-height:0;"></div>


(system) #8

OK, thanks for the suggestions.  I will be back at it shortly today.

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of Jose Gomez
Sent: Thursday, October 17, 2013 7:16 AM
To: Vantage
Subject: Re: Re: [Vantage] RE: Com port customization - need some help

 

 

Yes, I would imagine if you want to save it on Part Tran you should assign to the epiview for PartTran (if available) other times what i've done is because the Part Tran table is not available I would assign it to a Charxxx in antoher one of the views and then us a Post Proc BPM to copy the fields over.



Jose C Gomez

Software Engineer

 


T: 904.469.1524 mobile


Quis custodiet ipsos custodes?

 

On Wed, Oct 16, 2013 at 10:44 PM, <kschoenung@...> wrote:

 

I am not sure that will work on this form.  Since there is a work list, I know the results go to Part Tran, but I am not sure about which view is really there as you add to the work list...The main fields show they are bound to the PartTran table, so I bound these new fields there also.  Are you suggesting that even though I assign to the epinumericeditor.value instead I need to assign to edvPartTran parttranrow("Number01") - even though it is not yet saved to Part Tran? 



---In vantage@yahoogroups.com, <vantage@yahoogroups.com> wrote:

I would assignt he value to the EpiDataView they are bound to.



Jose C Gomez

Software Engineer

 


T: 904.469.1524 mobile


Quis custodiet ipsos custodes?

 

On Wed, Oct 16, 2013 at 10:20 PM, <kschoenung@...> wrote:

 

Thanks Jose, do you know how should I be adding them to the fields?  Assign value to epinumeric editor or another way? 



---In vantage@yahoogroups.com, <jose@...> wrote:

Karen,

Depending on how the COM port values are added to the field it may behave differently.



Jose C Gomez

Software Engineer

 


T: 904.469.1524 mobile


Quis custodiet ipsos custodes?

 

On Wed, Oct 16, 2013 at 5:08 PM, <kschoenung@...> wrote:

 

Hi all,

We have some code for reading information from a scale into Job Receipt in inventory.  The code is working to read in the values, but results are different from when manually entering values and when receiving in the values via the com port - any ideas?

For example, we have the screen all fileed in and click OK, but nothing appears in the work list (no customization done to the OK button).  If we manually fill in the values, we are able to click OK and save the record.  Also, tabbing through some fields (bins for example) clears out the values that I have in the new numeric editor boxes bound to PartTran.Number01, Number02, Number03 (fields for the scale).  Any ideas why the behaviour is different for manual entry vs com port receipt entry?

Vantage 8.03.409C