Can't delete Part - used on a job

part

(Jim Shipley) #1

New to Epicor here… Working with some parts and I want to delete a Part. It says ‘Delete not allowed. Referenced by at least one Job.’ How do I find what job it’s on? Is there a BAQ or something I can create?

thanks


(Jim Shipley) #2

Actually what I really want to do is change the UOM Class, which is greyed out. Probably greyed out because it’s used on a job. So how do I change the UOM class?

thanks


(Calvin Krusen) #3

Changing UOM class is a MAJOR PAIN (when it can even be done).

If there were part transactions for it, you probably can’t change now. If it is on a job that that hasn’t had any activity, you need to remove it from the job.

You first step should be to use the Part Transaction History tarcker to see if the part has been used.


(Jim Shipley) #4

Ok, there’s no part transaction history for it. So how do I find out what job it’s on?

thanks!


(Calvin Krusen) #5

Use TIme Phase. It should show all the jobs it is used on.


(Brandon Anderson) #6

You might have to make a BAQ if the part is called out as an assembly because assemblies in a job will not show on time phase. look at the JobAsmbl table to find it.

edit: Here’s a BAQ that we use to look up parts by job. We have it in a dashboard (pictured below) that we use all of the time to find what parts are on jobs. The overall dashboard is huge, so I won’t export that, but the query should get you close. It’s a union query that puts together the Job Materials and Job Assmeblys in one grid so it’s easier to search.

JobBom.baq (41.9 KB)


(Calvin Krusen) #7

I may be wrong, but the OP sounds pretty new to E10, and a BAQ and dashboard may be throwung him in the deep end.

If the part is in a BOM, shoukd be able to find it with the Where Used report. Then serach for jobs to make that part.


(Calvin Krusen) #8

I assume this is referring to the part in question being the Assembly’s P/N itself. Like ASY-001 in the example below.

BOM FOR ROCKET SKATES
MtLSeq  PartNum    DESC               QTY
======  ========== =================  ====
10      STK-001    ROLLER SKATES        1 EA
20      STK-002    DUCT TAPE           20 IN
30      ASY-001    ROCKET MOTOR ASSY    2 EA  (PULL AS ASSY)
40      ASY-002    RR TRACKERS          2 EA

So if you had zero stock on hand, the Time Phase report would include STK-001, STK-002, ASY-002 and all its components, and all the parts that make up ASY-001. But not ASY-001 itself. That correct?

Or would the components of ASY-002 only appear if a job exists for ASY-002 or if MRP was run?

Does a part designated as Pull As Assy show up on the Where Used report?


(Brandon Anderson) #9

The where used would show where it goes, but depending on the structure of your jobs, that may not be enough to find them on the job, or know that you have them all. Also keep in mind that the job and the part master can differ, so in some cases the where used might not help you. If you run MRP and have only single level BOM’s then simply time phase would work. In our case, a BOM is 6 or more levels deep, because we make nearly everything on one job, and don’t run MRP.

@jimship is the part in question a raw material?


(Himal Gurung) #10

You could create a new revision for the part. and then you could be able to change the part UOM via part entry. I havent tried it myself though. See if it works.

I tried it. doesnt work.


(Jim Shipley) #11

Sorry - I have been taken off this for now. I’ll get back to it later today but don’t want to leave you hanging. Thank you for the responses. I will get answers later today hopefully…


(Brandon Anderson) #12

@hymal7, I’m interested in your thought process on that one. The UOM is on the Master Part, and the revisions do not have a UOM. How would creating a new revision allow a change to the UOM?


(Himal Gurung) #13

Ya I guess I was wrong there. I assumed the new revision’s part details would be a copy of the original revision’s part details with no connection to transaction history/demand. Very wrong. So is a new revision only helpful when changing part operations and materials then?


(Brandon Anderson) #14

Well, I did a little testing, and if the part isn’t used anywhere yet, but has a revision, it doesn’t let you change the UOM class. I thought that was odd, and if you make a new revision, you are right, you can change the part UOM class. I don’t get why. If there is a rev A, you can’t change. But if there is a rev A AND and rev B, go ahead and change it??? That doesn’t make any sense to me why it works that way. It’s probably easier to just remove the revision if there is one, then re-add it, as long as it isn’t used anywhere. (You can clear out untransacted requirements on jobs by deleting them, and you will need to remove them from any BOM’s they are on as well, but then you can re-add them after the UOM change)

If there is transaction history, you are screwed either way (like you mentioned)


(Brandon Anderson) #15

I meant to answer this a little better too. Calvin you are correct, here is an example. The part I show here is a middle level pull as assembly part. You can see in the time phase that there is nothing showing for that part.

The top level shows in time phase for a receipt on the job. This is the only assembly that will show in time phase because it’s what the job is for.

So if the part in question is a mid level assembly, you need a BAQ to find it. I don’t know of any Epicor native screens that will look for those parts. Does anyone else?


(Jim Shipley) #16

I think, for now, I am going to just create a new part and continue working and I will get with our implementation consultant when he is back to work through this. Thank you all for the help! Much appreciated, this is a great resource.

Jim


(Kristine Fierce) #17

Have you looked into using Part UOM Conversion Maintenance? It i s not a program I would use frequently but I have had to use it a couple of times. I can’t remember all the different rules before you can update the part class and UOM but no inventory on hand. You also need to be sure the UOM you are coming from is present in both the from class and the too class.

Try it out in a test environment so you are sure that it will do what you need it to do. It is possible. Program is located in System Setup -> System Maintenance