Can Extended Properties be added to a Solution Workbench?


(Dan Godfrey) #1

Does anyone know what ElementHeaderID in the Solution Workbench will pull in Extended Properties?


(Jose C Gomez) #2

Haven’t tested it, but maybe through the User Defined Tab


(Surendra Pal) #3

this should work for you. ZData for Dataset and ZDatatable for UD tables(user define fileds)


(Dan Godfrey) #4

@surendrapal, I tried to pull in both ZDataSet and ZDataTable and I still did not get the UDLabels on my UD01 table. Do you think that one of the two over-rode the other?

I am going to make solutions only for the three option independently: ZdataSet, ZDataTable, and (@josecgomez idea) the ZDataFieldSearchAdapter.

I am going to get to the bottom of this.


(Dan Edwards) #5

The method @josecgomez works just fine. You can take this a step further and define your own element for use in Solution Workbench. Here is example.


Then you get this when adding to a Solution
image

(Dan Godfrey) #6

Ok, so I tried the ZDataField option. My first attempt I thought it did not import correctly, so I decided to redo it. I watched the solution build this time and realized that the build failed. An example of the repeated eorror, 1 for eaxh extended proprty, is this:

[4/2/2018 7:40:24 AM] Unable to retrieve the row from Ice:BO:ZDataField with SysRowID ‘9829e32b-8abe-4566-9941-074c95a92525’.

Does anyone have any suggestions? If not I think I am going to try through the DMT. I found “Extended UD” which looks like it will do the same thing.


(Dan Edwards) #7

Can you post how you created the element entry? Also, can you post a screenshot, similar to the one below, that shows what you are adding?


(Dan Godfrey) #8

So here is the solution and build, with the error message.

Error.txt (5.0 KB)


(Dan Edwards) #9

If you create an element entry for ZDataField, like I posted above, it will work.


(Dan Godfrey) #10

I don’t see the difference from your image and mine. Can you explain more?


(Dan Edwards) #11

DId you add this ?
image