Auto update error about optimized assemblies


(Adam Tuttle) #1

Hello everyone. My first post, please let me know if this is in the wrong place. I’m the Network Administrator at my company, not the Epicor team, so bear with me here.

We are going to upgrade from E9 to E10. I’m running some tests on the installation of E10, and ran into an error message that none of us understand.

I install E10 using the E10client.exe program. Everything goes well here. Then I edit the shortcut to use the program EpicorStartup.exe instead of mfgsys.exe. This program pulls down the latest DLL files from the server before presenting the login screen. When I run EpicorStartup.exe for the first time as an admin user, it works great. If I run as a restricted user, I get the following error.

“You must be running as an administrator to optimize assemblies. The application will run unoptimized until an administrator can optimize the assemblies.”

I searched for hours and couldn’t find any information about this error. Does anyone know what this error means? Or the implication of the error? The autoupdate works for both admins and restricted users. And Epicor still runs after the auto-update. But no one here at my company is sure what this error is, or if it’s something to worry about.


(Utah Taylor) #2

Have you tried calling Epicor Support? They have a specific team for upgrades and installation issues.


(Nathan your friendly neighborhood Support Engineer) #3

Never be afraid of contacting Epicor Support, especially before a holiday–it’s really slow and we’d love the company :slight_smile:

  1. Right-click on the Epicor shortcut and select “Open File Location”.

  2. Open the Config Folder.

  3. Right-click on the .sysconfig name that matches your appserver name (or, just look at the shortcut properties > target line. after /config=xxxx.sysconfig, that is the one you want to look at) and open with your text editor of choice.

  4. Search for <optimizeAssemblies

  5. if it is
    <optimizeAssemblies value="true" bool="" />
    change to
    <optimizeAssemblies value="false" bool="" />

  6. Save your changes.

  7. Launch the client again.

NOTE: I supect that this setting is originating from the server’s sysconfig, so to prevent new client installs from having this problem

  1. Navigate to \EpicorServerNameGoesHere\ERP[ReleaseNumberGoesHere].0Deployment\Client\config.
  2. Open each of the syconfig files in your text editor of choice.
  3. Change the `<optimizeAssemblies value to false (as appropriate)
  4. Save your changes.

(Adam Tuttle) #4

Hi there,

Thanks for your reply. I found the optimize parameter in the configs. Every config, both on the PC and server ERP share, already have it set to false.

Either it’s pulling from a config I can’t find, or the optimization is automatically triggered on a new install.

Either way, I can just click through the popup message when I perform the installs. My main concern was if running “unoptimized” files would cause any issues in E10. It doesn’t look like it does, so no issues here.

Once again, thanks for your reply.

Adam