Adding Custom Crystal Reports to Vista 8.03

crystal
(Mark McClure) #1

I’m a new user to Vista 8.03. I created a custom Crystal Report by connecting Crystal Reports to our Epicor Server.

How do I now add this report to Epicor for users to run the report? Everything I read says to go through Report Data Definition, but I do not need to do this as the Data Definition has been called out already in the crystal report?

Any help is greatly appreciated.

0 Likes

(Calvin Krusen) #2
  1. Create a New Menu item.
  2. For menu item type select “Crystal Custom Report Link”
  3. Browse to the RPT file

Disclaimer: I’m currently on E10, and its been a few years since V8. So I sometimes confuse the two, stating something in E10 is available in V8 (when it isn’t)

0 Likes

(Mark McClure) #3

Ok, this worked, however when I click the new menu item, it is asking me for database connections etc. Is there a way to bypass this or default it to the correct path to the server?

Also, can I add it to just the Reports folder and not a standalone item?

0 Likes

(Calvin Krusen) #4

In E10, I get a “blank” run report window that launches when I click the menu Item added as above.

image

I don’t have to actually fill in the name or password.

Clicking the Preview button launches the CR runtime viewer.

You could make a BAQ Report with a very simple BAQ (just query the Company table), ten in the CR rpt for that BAQ Report, put your non-V8 CR rpt in it as a sub report.

0 Likes

(Mark McClure) #5

When I click the preview button in 8.03 it asks me for this information:

image

0 Likes

(Calvin Krusen) #6

Ahhh yes… That’s looking for connection info to the Progress data base.

You’d need to enter the username and password from PET (Progress Explorer Tool). I think the defaults are ‘progress’ and ‘progress’

Any reason why you don’t want to do it as a BAQ Report?

And in the example I tried (in E10), I made the DB connection in CR via and ODBC connection, not directly through Progress

0 Likes

(Mark McClure) #7

Quite frankly, I don’t know how to do a BAQ report. Can you walk me through how I can use that to connect to my CR report?

Thanks again for your help here…as a new Epicor user this is greatly appreciated.

0 Likes

(Calvin Krusen) #8

It’s been a while …

(The following is from an old post I made back in August of 2011.)
The basic steps are

  1. If necessary, make changes to BAQ.
  2. Copy the baq report from “W:\mfgsys803\Server\reports\CustomReports” to “C:\Documents and Settings\All Users\Application Data\Epicor\Vista\8.03.403D\MC\shared\Reports”. These to paths are setup in BAQ Report Designer under Actions\Options.
  3. Launch BAQ Report Designer and load the BAQ Report
  4. If necessry make changes to BAQ Report settings (Options, Filters, Sorts, etc…)
  5. Run the Actions\Test Report Form
  6. Select options, filters and sorts to make sure report will contain useful data.
  7. Do a Print Preview, and ignore the resulting report
  8. Copy the recently created XML file (which will have updated data and report parameters) from “W:\mfgsysdata\Reports\userid” to “C:\Documents and Settings\All Users\Application Data\Epicor\Vista\8.03.403D\MC\shared\Reports”.
  9. Close the Print Preview
  10. Close the Test Report Form window.
  11. Select Actions\Design Crystal Report.
  12. In CR Designer, select Database\Select Datasource Location
  13. In the upper pane, expand ReportDataSet
  14. Expand Properties
  15. Double click the File Path, select one character in the path\filename, and delete it.
  16. Press Enter (a window wil open asking for the ADO.NET (XML) info.
  17. Use Browse to select the copy of the XML file from step 8. Leave the Class field blank, and the Use Data… checkbox unchecked.
  18. Click Finish
  19. Click Close
  20. Select Report\Refresh Report Data( or just hit F5).
  21. Make whatever changes to the Report, save it, and exit CR.
  22. Select Actions\Deploy BAQ Report form the BAQ Report Designer window.

Some explanation …

  • The “W:” in “W:\mfgsys803\Server\reports\CustomReports” was a mapping to our V8 server.
  • C:\Documents and Settings\All Users\Application Data\Epicor\Vista\8.03.403D\MC\shared\Reports
    was a folder (probably for Win XP) on the client computer
0 Likes

(Mark McClure) #9

Thank you! I think I’ll be able to add it as a sub report as you originally stated.

0 Likes

(Mark McClure) #10

I went through and added this crystal report as a subreport in a basic BAQ report. I added it as a menu item and I am able to execute the report on my machine.

However, when another user goes to execute the report on their machine, it just says “report submitted for preview” and never executes…any suggestions?

0 Likes

(Calvin Krusen) #11

Can the other users run the Crystal Report you made, outside of V8?

Is the BAQ your BAQ Report built around setup as Shared? (It’s a thing in E10, not sure if was in V8) If a BAQ is not Shared, only the creator can execute it.

0 Likes

(Mark McClure) #12

A ha! Thank you! I didn’t have it “Shared”

0 Likes

(Mark McClure) #13

I hope this is the last issue…when the user now runs the report it is giving this error message. Looks like it is looking for a file on her local C drive? Any idea why it would be doing this, and how to fix it?

error

0 Likes

(Calvin Krusen) #14

The BAQ report uses a sub-report, correct?

That sub report is located on the App server?

When you edited the BAQ Report’s .rpt file, did you specify a path to the sub-report that is “neutral”? Meaning that it doesn’t rely on drive mappings that may vary from client to client (or even client to App Server).

When in doubt, use a full URL like:

\\V8_AppServer\MfgSys803\Server\Reports\Custom\Custom_CR_report.rpt

that way it can be found regardless of point of view.

0 Likes

(Mark McClure) #15

Yes, the subreport and the BAQ report files are both located in \V8_AppServer\MfgSys803\Server\Reports\CustomReports folder.

Any other ideas? Could it have anything to do with the BAQ report options? There are several paths called out there such as Local Reports Directory and Server Reports Directory?

0 Likes

(Calvin Krusen) #16

I assume the user can run other CR based reports.

Make a copy the rpt, and remove the sub report. See if the user can at least run this new “blank” report. If they can, than it has something to do with the sub report.

0 Likes

(Mark McClure) #17

You are correct it is something with the subreport. Some how I need to link my BAQ XML data and the non-BAQ sub report data. Found this old post from 2009:

Subject: RE: [Vantage] non-BAQ subreport in BAQ report

I’ve used this technique multiple times when the Vantage BAQ just
wouldn’t do everything I needed.

You can join multiple datasets very easily using Database Expert.

A couple examples that I’ve done:

  • I have used the BAQ Export Process to dump a virtual table to XML
    and joined to that using Crystal Reports.
  • I have joined to an MS Access table to display related payroll info

If you can relate the tables (ie, Part.PartNum <–> MSAccess.PartNum)
then you’re golden. Crystal Reports doesn’t care where you get the
data.

I will give this a try

0 Likes

(Mark McClure) #18

This did not work, still receiving the same error on the users machine.

0 Likes

(Calvin Krusen) #19

Is your report’s data set so complicated that it can’t be done as a BAQ?

If at all possible make the report entirely in V8.

  1. Make a BAQ. Its okay if it returns more data than you need. Making the BAQ Report will allow you to add parameters & filters.
  2. Make the BAQ Report. Try to get the BAQ as close to finished as possible. because it’s a pain to update CR to see the new dataset when the BAQ changes.
  3. Modify the rpt file with CR.
0 Likes

(Mark McClure) #20

It’s a little complex, trying to link shipments back to part numbers and their standard cost. It can certainly be done in a BAQ, I’m just more familiar with linking tables through Crystal and am finding the BAQ in Vista to be more difficult.

Looks like the BAQ in recent Epicor versions looks easier, and more visual based with the linking.

I will give the BAQ a try, thanks for your help.

0 Likes