10.2 Upgrade: Can't get past Conversion Workbench


(Luke J Reynolds) #1

I’ve got my application server up and running on a VM, and I’ve already started up the client and run the conversions in Conversion Workbench. Once they were finished I hit File-> Exit. But every time I try to open the client again, it gives me the same message about needing to run Conversion Workbench before I can run anything else. How do I get past this?


(Graeme Fraser) #2

have you logged in as Epicor or a security admin?


(Luke J Reynolds) #3

I logged in as a security admin.


(Graeme Fraser) #4

are any conversions failing?


(Luke J Reynolds) #5

A few are “Complete With Errors,” but there is one failed conversion. “PCConv905”, and its log says the conversion has already been applied. Were’ upgrading from 10.1.400, if that’s relevant here.


(Nathan your friendly neighborhood Support Engineer) #6

click on user run conversions
select the latest 10.2.100.x conversion description there and rerun that.
log out and back in.
win at life?


(Nathan your friendly neighborhood Support Engineer) #7

NO ONE ELSE EVER RUN THIS EVER UNLESS SUPPORT SAYS IT’S OK FIRST!!!

Run this to mark this conversion as complete in SQL

update ice.cnvprogs
set ProgStatus=‘COMPLETE with ERRORS’, ProgressPercent=100, runuserid=‘manually_set_to_complete’
where ProgStatus=‘ERROR’

and try to log in again


(Luke J Reynolds) #8

Alright so that got me past Conversion Workbench! Now I have a new problem: The 10.2 client will function for a few minutes, just long enough for me to open a form and load a record, and then if I try to do anything after that I get “Server timed out” messages and the client stops working. This is happening on a very, very slow VM, is this a hardware issue or did I do something wrong with Epicor?


(Nathan your friendly neighborhood Support Engineer) #9

do you have just a regular very slow VM instead of a very, very slow VM to load this on? :slight_smile:

< plug>
I just created a new concept knowledge article on the Performance and Diagnostic Tool that I’m interested in getting feedback on. If this is actually a useful format, I’m planning on doing this for every major area of technical support (SSRS report errors, appserver provisioning KBs, etc).
</ plug>

Can you install the PDT, run the config check and attach your results? (or, hopefully, even better, see if the KB article itself provides you enough info where you can address any of the failures you see)

KB0038815 KNOWLEDGE ARTICLE TABLE FOR PERFORMANCE AND DIAGNOSTIC TOOL (PDT) ARTICLES


(Luke J Reynolds) #10

I wish we had a regular-slow VM to test this on instead, but alas. I’ll poke through that article!


(Nathan your friendly neighborhood Support Engineer) #11

Just install the PDT and run the config check. It’s the first KB link in that article. If you post your Config Check output to this thread, would be happy to review it :slight_smile:


(Luke J Reynolds) #12

I fixed the slowness issue! Increasing the app server’s timeout limit from 300 to 1000 made everything run much better. Now I have a new issue, going back to the Conversion Workbench:

The INV/WIP report isn’t working and I think it’s related to the “Complete with Errors” result from the GL Posting Rules conversion, cvpe0000. System monitor lists the following as errors:


I don’t see any menu items called “GL Book Entry” and I don’t see where “Segments Mapping Setup” is in Book Maintenance, if that’s what I’m supposed to be looking for.


(Mark Bernhardt) #13

Did you find the answer to this mapping error Luke? We’re seeing this in our upgrade testing also!


Installing default transaction types
(Aaron Moreng) #14

If you haven’t done so already, part of my environment refresh is to import the GL transaction types.
FYI I’m not a consultant so do this at your own risk, and I also don’t have any custom posting rules.
Go to General Ledger>Setup>GL transactions Types>Actions

Select Import GL Transaction Type.
Click Load Transaction Type and select Import All, Replace All, Change All Revision Statuses to Active, and change the “Rename all Selected Revisions To:” some value that makes sense to you. I usually just put the version number (1022003). Or, you could just load the ones you are missing mapping for.

This will prompt a form saying that it will block all older revisions. I click ok.
image
Next, it takes you to the Books and GL Mapping form. For each transaction type, you will need to select the Target Book as well as re-map any accounts.

Some GL Transaction types simply need the book defined, but others will need the segment mapping as well.


In this example, I map the AP Invoice GL transaction Type to the target book but it doesn’t know what to map “Chart” to. I know that for “Chart”, I map this to Natural Account, but your setup could be different.

I basically just do this for all the GL Transaction types. They will change icon from a “!” to a file looking icon when you’ve addressed them.
After doing this for each one, I click Ok.
This will then take you back to the Install Default/Import GL Transaction types and will show at the bottom left a dialog of what it’s importing.
When it’s done, you’ll get this:
image


(Haso Keric) #15

From Derek D - Who has consulted Epicor Support on the matter.

This is an expected issue because there is new functionality introduced which opens up new options for the main fiscal book. If you are using “extended” that is fine, however the package segments have to be changed to match the expected target segments. Changing this is ok to do with the UI but it is per company and requires you to change the default package and package type from extended to standard, update the target segment, click save, then change it back to extended. The screenshots below detail out the process steps to perform this action.




Once this has been done for every company, then execute the autorun conversion 540 again and it should complete without errors, as noted below.


(Simon Hall) #16

Our issue appears to be that when you try to select the default package and segment map there is nothing to select. Has anyone seen this issue before?


(Tanner Post) #17

@hally We’ve seen a similiar issue when we missed a step in the upgrade document from 10.0 to 10.1. There is a file in the Server directory (Erp\PostingRules\ConversionParams.xml). I believe this file needs to contain the segment definition prior to running the database upgrade.

Thanks,
Tanner


(Simon Hall) #18

@T11 I’ll take a look at that. Although this environment was supposed be a direct 10.1 install.


(Simon Hall) #19

Hmmm,
I looked at the conversion params table and compared them between the working environment and the non working and there is no difference. From a segment issue our segments do have Division and Department swapped, but XML file comments it says not to change.

Anyway the case is logged with support and one particular support consultant that we all know and respect, is helping us out. :slight_smile: